0

This question already has an answer here:

I have several problems with windows 10 language bar. I use English as my base language for windows, but I do need keyboard layout for Latvian language as well. I have read other similar topics, but I feel that none of them really apply to my situation.

The problems:

  1. If I put computer to sleep mode and then turn it back on after a while, all languages and keyboard layouts that have been added some time in the past and removed after, suddenly appear in the language bar. If I go to "language preferences" these new layouts and languages aren't there, so I can't remove them. If I shut down PC and turn it back on they are gone.
  2. Currently I have 1 language and two keyboard layouts, one for English keyboard and one for Latvian keyboard. And the keyboard layouts keep changing all the time. For example, I open new mail window, I change the keyboard layout to Latvian and start typing, then I need to check something in Internet browser, I come back to outlook window and my keyboard layout has already been changes, so I have to set the layout to Latvian again. This may sound like a small problem, but if you have to do this often during the day, this does get irritating fast.

I did find one solution that works for me, more or less, but it's by no means perfect and it is only a solution for the fist issue. I added Latvian language with Latvian keyboard layout and set Latvian language as primary language, but that translates apps and other things in Latvian, which I definitely don't want. The fact that I did enable "Display language (ovveride)" on English language doesn't help as well.

Edit: several people have marked this question as a duplicate, but I would like to clarify that it is not a duplicate question, here is why.

In the original question author mentioned that:

1.The keyboard language keeps switching to English constantly

  1. I can't see the language bar nor the language toggle popup when I swap:

Where my problems are:

  1. after computers comes out of sleep (only sleep) keyboard layouts that are not even present and are uninstalled are added to the language bar, they only disappear after system restart.

  2. During normal working mode language keeps switching all the time (explained in more detail in original question)

Could you please clarify how is this the same issue? Although similar it is quite different. Before starting this topic I actually did read the question which mine is considered a duplicate of and I did try those fixes, but they didn't help unfortunately.

marked as duplicate by Ramhound, fixer1234, DavidPostill windows Dec 13 '16 at 10:21

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Did this problem always exist? – Ramhound Dec 12 '16 at 18:10
  • I think yes, I noticed it quite a while ago and was living with it until now. While the symptoms in the other thread are similar, it's different. The person there is complaining about language bar not being visible at all. And solution in his case was to add keyboard layout, which I have already done. – Uldis Dec 12 '16 at 18:39
  • You have uninstall the keyboard layout and reinstall it for the version of Windows 10 you currently have installed? – Ramhound Dec 12 '16 at 19:19
  • I did try uninstalling and installing keyboard layout as well as languages themselves for several times. – Uldis Mar 14 '17 at 14:00