-1

I have two hard drives - first one with 2 TB and system installed on it and sees its fine (Windows Server 2008 R2 Enterprise). It has MBR partition style.

And a second clean hard drive with 4 TB, which has GPT partition style(no systems installed), but system sees only 2 TB.

How can I make to see all 4 TB?

Actually, I have an option to copy my frist hard drive to 4 TB disk with Acronyc if it helps.

  • Did you make your disk online in the disk management? – Dylan Rozendom Dec 14 '16 at 10:50
  • @DylanRz yes it is online – Il'ya Zhenin Dec 14 '16 at 10:51
  • It’s possible your disk controller is not compatible. Are you using the onboard SATA controller? What’s the motherboard’s make and model? – Daniel B Dec 14 '16 at 10:54
  • @DanielB I don't know about motherboard, it's old(about 2009) and all info that I was able to get "Dell Inc. 06P7W2", there is no such model in google now. Hard drive this one: newegg.com/Product/Product.aspx?Item=N82E16822235128 – Il'ya Zhenin Dec 14 '16 at 11:14
  • Hm, a Dell OEM board. However, the chipset (5520/5500) should have no problem supporting bigger disks. – Daniel B Dec 15 '16 at 7:53
1

@Il'ya Zhenin!

I'd advise you to go to Disk Management and make sure that you don't have the 2 TB of your 4 TB WD Black as unallocated there. Sharing some screenshots would really helpful to us. If nothing works, I'd strongly recommend running the WD Data LifeGuard Diagnostics and more specifically its WRITE ZEROS feature. It will FULLY ERASE the drive - getting it back to its factory default (out-of-the-box) condition. However, you should definitely back up all your data from the WD Black somewhere else beforehand. The erase will take some time and it will make all data unrecoverable afterwards, so make sure you copy it somewhere else to avoid the data loss. After that, you should again be able to Initialize the HDD in GPT and then Partition & Format it.

I hope this helps you.

Keep us posted if you have more questions.

  • Thank you for answer. In disk manager it was allocated completely. I tried to erase disk as you suggesting with WD tool and I did. After that I enter disk manager once again and it asked me for choosing partition table - I choosed GPT. But it is once again just 2048 GB :( I can't load pictures because of proxy restriction. – Il'ya Zhenin Dec 16 '16 at 16:16
  • This sounds pretty unfortunate, @Il'yaZhenin! :( I'd advise you to check the warranty on your WD Black here, if it's still covered, you should be able to RMA it and get a replacement drive from our Customer Support. Have you tried formatting it from another working PC as well? Maybe you should give it a try and see how it goes. Keep me posted, though. :) – SuperSoph_WD Dec 19 '16 at 10:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.