0

I have a home network with an HP Laserjet 4000 on it, accessed via a Jetdirect 600n card. The printer works fine on other machines (including those running Windows 7x64). The network address (192.168.2.211) is accessible from the laptop via a browser without issue.

I cannot install the printer onto my laptop. When I try to install it via the "Add Printer Wizard", the wizard detects the printer type and the IP address without issue. When I click "Next", i get the error "Cannot Load Wizard Pages for standard TCP/IP Port".

If I install the printer first as a local (LPT-based) printer, and then try to add the TCP/IP port, I cannot do this - when I click "Add port" in the properties page, I get a list of "Printer ports", which does not have Standard TCP/IP port as an option.

What I have already tried: Creating the registry entries to re-enable the "Standard TCP/IP Port" option, as seen on this site - i.e. the following: "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Print\Monitor\ Add key Standard TCP/IP Port Add String Value; value name=Driver; value data=tcpmon.dll under Standard TCP/IP Port Add Key Ports Add three Dwords in Ports LprAckTimeout value data= 180 StatusUpda****abled value data= 1 StatusUpdateInterval value data= 10 stop and start spooler This hasn't worked; I also exported that registry tree from another Windows 7x64 machine which does work, and imported that. Still not working.

Checked on the files that are used for TCP/IP Ports and they are all there: in \windows\system32 tcpmon.dll tcpmib.dll tcpmonui.dll I don't have any of the files that have been references in the %systemroot% folder that would cause conflicts: Wsnmp32.dll, Ntprint.dll, Tcpmib.dll, Mgmtapi.dll, or Snmpapi.dll

Run sfc/ scannow - this apparently found corrupt files but was unable to fix some of them. The CBS.log file is unreadable, oddly.

In short, I'm out of ideas. It's not often that I can't find a solution for a computer problem, and I have done a lot of looking - all of it has pointed to the solutions above which haven't worked. Judging by the searches I've seen, I'm not the only one. Help would be appreciated.

  • "Run sfc/ scannow - this apparently found corrupt files but was unable to fix some of them." Fix your repository until SFC finishes without error. Otherwise we have to assume its probably due to a corrupted system file that you haven't fixed via SFC yet. – Ƭᴇcʜιᴇ007 Dec 15 '16 at 16:48
0

Fixed the issue by removing the drivers and printer values under

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows x64\Print Processors

older and installed printers/drivers that can't be used by Windows 10 kept causing the printer sub system to crash and not work.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.