2

I've been trying to diagnose this problem for a couple of days now. I've narrowed some things down.

Issue Summary

Previously, I had a 2x4GB DDR3-1600 MHz kit (CMZ8GX3M2A1600C9) running in dual channel mode on my motherboard. The motherboard has 4 slots and supports up to 32 GB and 2133 MHz.

I purchased a 2x8GB DDR3-1600 MHz kit (CMZ16GX3M2A1600C10) and immediately started having issues. Random BSoDs showing error c000021a, sometimes I can boot into Windows but the resolution is wrong, graphics card is not detected properly, other components fail to appear, applications fail to launch, etc. Running either of the DIMMs alone works in every slot.

Working Configurations

  • 1x8GB in any slot
  • 1x8GB + 1x4GB in slots A2/B2
  • 2x8GB in slots A2/B2 + 1x4GB in slot B1

Strangely, the presence of another DIMM in a separate channel causes the 2x8 kit to behave correctly. The 4GB DIMM in question is from the previous 2x4 kit.

Ideal configuration is to run the 2x8 kit in A2/B2 for a total of 16GB.

What I've Tried

  • Tweaking BIOS settings to ensure correct MHz were being applied
  • Tried each DIMM in every slot
  • Lowered speed to 1333 MHz
  • Tried enabling X.M.P. Profile #1
  • Used "OC Tuner" to automatically set clock speeds
  • Applied default settings in BIOS
  • Performed a full power cycle, unplugged cord, switched off PSU
  • Performed full BIOS reset with jumper
  • Updated to latest BIOS
  • Two full passes of both Memtest86 and Memtest86+ showed 0 errors
  • Confirmed both sticks are truly identical via CPU-Z
  • Tweaked CAS timings
  • Slightly increased voltage (1.5 to 1.52)

The Kicker

When I install one of the older 4GB DIMMs alongside the new 2x8GB kit, everything runs fine. No more BSoDs, no driver or performance issues, etc.

https://i.imgur.com/ThO8mSn.png

Notice that CPU-Z sees the 4GB DIMM with a lower bandwidth of 667 MHz even though it tests at 1600 MHz. It also has an older XMP version and the CAS timings are different. I've tried to adjust the CAS timings for the new kit to match the older one and this yielded no results.

This has led me to believe it has to do with the motherboard settings, as when the 4GB is installed, something must be changing that allows the 2x8GB kit to behave.

What am I missing here? Why does the 2x8GB kit misbehave but running either 8GB DIMM alone or running both alongside a 4GB DIMM works fine?

  • Verify you running similar modulars in the same channel. The behavior you describe would exist if you were running dissimilar modules in the same channel. – Ramhound Dec 15 '16 at 19:29
  • They are identical DIMMs. They came in a kit together. Corsair Vengeance 16GB (2x8GB) CMZ16GX3M2A1600C10. I even manually confirmed it by running each DIMM separately and checking CPU-Z. – Gsinti Dec 15 '16 at 21:16
  • Your response doesn't really answer my question. I was asking you to make sure your using the 4GB in one channel and the 8GB in the other channel. Sometimes the layout of the channels are not straight forward. Provide us the manual and the slots your using for each stick. – Ramhound Dec 15 '16 at 21:18
  • Ah, I see. Yes, I am running the 2x8GB in the same channel and the 4GB is in a different one. Slots A2/B2 have the 2x8 and slot B1 has the 4GB. When I remove the 4GB from slot B1, the issue returns with the 2x8 still in the same channel. The OP has a link to my motherboard with the manual under the support tab. – Gsinti Dec 15 '16 at 21:26
  • You are 100% sure that A2 and B2 belong to the same channel? That does not match my personal experience with my own motherboards. – Ramhound Dec 15 '16 at 21:28
0

Never found a true solution, but I had been planning to upgrade to Windows 10 for some time. I did that tonight and then tried putting the 2x8GB kit back into the machine on its own. The issue is now gone.

It seems Windows 7 was somehow the culprit, but it doesn't explain why the 2x8GB kit worked fine alongside an additional stick of 4GB. It must have been related to software in some way.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.