I need to start a virtual machine on Windows Startup and read about move the virtual machine to the "Shared VMs" tab. This worked for me since now when I need to auto start a Virtual Machine with a Physical Disk reference. By default VMware Workstation won't allow you to do this if you are loading a physical disk (from host machine).

I started to search for a solution and found some info about the "vmrun" command which allows you to start a virtual machine using the Windows Console (cmd.exe). Turns out that it works! If you execute something like this:

vmrun.exe -T ws start "D:\VM\Name.vmx"

The virutual machine starts immediately. So far we are good. Now, If I create a batch script (.bat) with the same line and configure the system to execute that batch file on startup nothing happens and I got this system prompt:


Also I got my VM blocked and force me to Take ownership, which I can't and finally offers me the alternative to Remove the VM from library.

This confuses me because I can start the VM from a command prompt but I can't do the same using a .bat file.

PS: I modified the windows environment variables to allow me to type only the vmrun command without pointing the entire path to the .exe. Somehow the system tries to execute the Virtual Machine (which says the .bat is executed) and finally can't do it completely.

**Post edit: I'm using the NSSM program to set other programs to run as services, which by the way I found in this great platform.

1 Answer 1


If you've scheduled a task to run without a user being logged on (which you have, because nobody is logged on while the system is booting up), the program cannot display any user interface because it runs in a session intended for only background services. Windows tells you about this situation with that message.

To start a VM with the vmrun command with no UI, add nogui at the end, like this:

vmrun.exe -T ws start "D:\VM\Name.vmx" nogui

(Source: this PDF VMWare manual.)

To fix the VM thinking it's in use, you need to delete or move the .lck or .lock files/folders from where the virtual machine is stored while VMWare Workstation isn't running. (Source: VMWare forums.)

  • Oh man, oh man, oh man. This solved my headache about this issue. By the way I faced this same problem in VirtualBox and finally drop the flag. Now finally have the solution. Im still getting the windows prompt and I don't know why but, who cares? My VM is running in background! :) :) In your face Interactive environment.
    – ppdmartell
    Dec 15, 2016 at 20:57
  • Seriously, I read something related to do not say thanks on posts but anyway THANK YOU!
    – ppdmartell
    Dec 15, 2016 at 20:58
  • Thank you, 6 years later and this is still a solution to an incredibly annoying deadlock situation where a VM is not starting through Task Scheduler if "nogui" is not set as a parameter, the VM attempts to start up and just hangs at a certain point, with no way to interact with it except shutting down its task through TaskMgr. I have 3 VMs running in a System, 2 start without nogui, the third one made me waste hours troubleshooting the issue...I didn't even get the message that the VM was attempting to display something because it had nothing to display, it simply hangs, ridiculous... Jul 4, 2022 at 6:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.