0

I'm trying to set up file transfer via FileZilla and it doesn't seem to matter what details I put in, I always get the following error:

Status: Connection attempt failed with "ECONNREFUSED - Connection refused by server". Error: Could not connect to server

My Dad has tried on his computer (with FileZilla on Windows) and it connects and everything is fine.. When I try on mine with all the same details that he put in, it comes up with that error.

I read that a firewall might be blocking it so I double checked and my firewall through system preferences and it is off.

Anybody know why this might be???

Additional info:

Macbook Pro running OS X El Capitan version 10.11.6

FileZilla version 3.23.0.2

0

So I got this working now. Although it's not a super ideal solution...

I used my phone as a wi-fi hotspot and used the wi-fi from that instead of the one at my flat, and it worked first time. Not exactly sure why, but I think it has something to do with this:

“NAT (Network Address Translation) routers. Many hosts and routers on the internet use the IPv4 protocol. The number of hosts connected to the internet has reached IPv4's design limit for the number of addresses (IPv6 is designed to relieve this). NAT routers allow multiple systems within a LAN to connect to the outside world with one external IP address. Unfortunately, both NAT and personal firewalls conflict with FTP more often than not. To make things worse, some are themselves flawed, causing additional problems regarding FTP.” - (source: https://wiki.filezilla-project.org/Network_Configuration)

I just have to figure out if I can change a setting somewhere to fix this on my normal wi-fi now so I don't have to keep running a hotspot from my phone.

Hopefully this helps some of you guys. I know how frustrating it is!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.