0

I have a no-name gaming mouse that resembles this one: http://www.e-bluegaming.com/individual%20product/ems108.html. On the box it was said it does not require any drivers (just like with the E-Blue one - there aren`t any drivers for ems108). However, this is only partly true. I experience very disturbing intermittent lag (the cursor freezes for a split second every 5 seconds or so). What is strange, this gaming mouse works fine on my Linux laptop, and another "regular" mouse works fine on my desktop as well.

I have searched everywhere for days, and that is what I tried, but still in vain, of course:

  1. Set both usb root hubs in Device Manager to always provide energy (there are two of them - Windows and Intel ones, the driver for which was included in my mobo Asrock Z170 Extreme4 driver set)

  2. Tweaked the Windows mouse settings in every possible way (however, I do not want to disable enhanced pointer precision - without it some games would be unplayable, and it also worked on my previous rig, which was based on Core 2 Duo, so it`s not about performance).

  3. Changed the ports, tried even with USB 2.0.
  4. Did virus scans with Avira, Malwarebytes and HerdProtect - nothing found.
  5. Performed a clean boot - lag still there.
  6. Uninstalled Avira - still nope.
  7. And the funniest part - lag is present even in safe mode.

My specs are:

i5 6600k

2x8 gb ram ddr4 2133 mhz

Mobo Asrock z 170 Extreme 4

Win 7 x64 ultimate

PSU Zalman Goldrock 650 W Gold (Enhance components)

GPU Asus Strix RX480 8 GB

So, not likely to be a performance issue.

I noticed some details also.

  1. The lag is intermittent and can end when plugging the mouse into another (or even the same once again) usb port.

  2. The mouse LED (that changes colors according to DPI) blinks slowly. Like, after 10 seconds it slowly changes to a blue color (that appears when there are no drivers for the mouse whatsoever i.e. BIOS without USB legacy mode) for a split second. However, the mouse pointer doesn`t lag at that moment.

  3. I`ve also installed the generic driver software package from the official website, but nothing helped as well.

P.S So I found the lag is present even in BIOS.

I know that buying a new mouse is a good option, but why does it work on another computer though?

Any help greatly appreciated.

  • Is the mouse connected to the front panel usb ports? If so, try connecting it to the USB ports on the motherboard, which are on the back. There may be a power issue with the front panel. – Peter Dec 17 '16 at 14:30
  • My mice are always connected to the rear USB ports. I also disabled C1E states in the BIOS - still nope. – Anvbis Dec 17 '16 at 14:43

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.