1

I performed a fresh installation of Windows 7 Professional SP1. Each time I turn my laptop on the clock shows time shifted exactly one hour back. I'm located in UTC +1 timezone, same for cities like Berlin, Paris, Madrid, Warsaw, Budapest and basically most of the Europe except for the UK.

What I have set up and what I did:

  • I have Internet time synchronization turned on with 'time.windows.com' as a source and it doesn't help. BUT when I manually click "Update now" the time updates to proper one!
  • I even added an additional clock and set up same UTC +1 timezone but for different cities (there are 4 UTC +1s inside Europe I can choose) and both have same, shifted time
  • I have Windows Time service enabled and set to Automatic startup (though I changed it while troubleshooting and it was "stopped" before)
  • I have correct time in BIOS (but it was totally different after disk formatting and I noticed it while troubleshooting)
  • I have regional settings correct
  • I have auto clock adjustment for Daylight Saving thing turned on

Additional info:

  • I have Ubuntu 16.04 installed on same disk and it's been always correct, also when BIOS time was wrong before correcting
  • I changed Windows installation, before I had Win7 Home OEM and now I have Win7 Pro acquired through my University <-> Microsoft agreement.

Interesting fact:

  • I was observing this behaviour since October and had a chance to see if anything changes after Summer-Time (UTC +2)-> Standard-Time (UTC +1) transition in late October. Before and after it was 1h back, so Windows recognised I'm in time-switching country and did a proper change.

I can't really think of any other options I could change/update/correct. What could have caused such a problem since win7 clean installation?

  • 1
    Linux keeps the hardware clock in UTC by default. So unless you changed either that or set Windows to do the same, that's a potential reason. – Daniel B Dec 17 '16 at 23:33
  • I do windows installations on a daily basis, and on each install, I always encounter that the clock is one hour back. I therefor always do the following: Disable time sync, then edit the time and adjust that one hour, then re-enable sync. I don't know how or why, but I'd say it has something to do with regional settings where microsoft introduced a bug or something. This happens for Windows 7, 8 and 10. Its almost as if windows syncs with a timeserver that is off by an hour during install. – LPChip Dec 17 '16 at 23:35
  • It never happened to me before when installing any Windows. but so far it starts up with correct time, after doing what @LPChip suggested. I need more time to confirm that ;) and I also haven't ever had to change anything in the registry to make time work, this would have been a huge bug if one had to do it after every installation. I will try that though if the sync-on-off method won't work. Thank you for your replies! – adamczi Dec 18 '16 at 0:35
  • It never needed to be done on a windows installation, only in recent months did I started to notice this, and it is with competely new installs only. Eg: harddrive taken out, replaced with a new one, then windows 7, 8 or 10 install. – LPChip Dec 18 '16 at 12:43
  • now this is exactly what I did. your method didn't work unfortunately, I will try the one proposed by Daniel B – adamczi Dec 18 '16 at 21:27

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.