1

I have been using the same laptop (Clevo p151sm1b, i7-4700MQ) for years and have had the turbo boost CPU multipliers reduced to 28x via Intel XTU. Recently, I did a windows update, restarted, and Intel XTU was suddenly not able to downclock my CPU multipliers to 28x anymore. All the CPU multipliers were set to a minimum of 34x for 1 core, 33x for 2 cores and 32x for 3 and 4 cores. To top it off, the UI for Intel XTU had changed even though I had not updated Intel XTU at all, but the version number was still the same. It used to show me an "advanced tuning" tab, now that tab was gone.

The updates that I installed on that day were KB3207752 and KB3205402, one of which is a .NET udate and one which is the december monthly security update for Win 7 64 bit. I also installed the windows malicious software removal tool, microsoft security essentials definition update and an amibigiously named "Intel System Driver".

This is the driver on the microsoft update site : http://www.catalog.update.microsoft.com/Search.aspx?q=Intel%20%E2%80%93%20System%20%E2%80%93%206%2F28%2F2016

Opening up the INF shows that it is an intel XTU device driver, but i do not know what files/modifications it makes or where. I tried to reduce my CPU multipliers in the BIOS for turbo boost, but I could not reduce them at all.

According to Intel, whether or not I can reduce my CPU multipliers is entirely controlled by my BIOS and XTU just reads that info from the BIOS. This makes no sense, as I was able to use XTU to reduce my CPU multipliers prior to this windows update, and I obviously did not change my BIOS, unless windows update modified my BIOS without telling me. Can anyone confirm what controls whether I can reduce my CPU multipliers for turbo boost? Is it soley the BIOS or can something else like a device driver interfere with it? I tried flashing my BIOS using the firmware that has been sitting on my USB stick for years (and was the same one I was using), but I still could not reduce my CPU multipliers.

I have tried updating XTU to the latest version, and also reinstalling the old version of XTU that I had (i still had the setup file saved on my HDD), but there were no changes. I still could not reduce my CPU multipliers.

Can anyone shed some light on what could be causing this? The theory i have now is that whatever i installed through windows update has left files in my system that are not removed by uninstalling XTU, which explains why XTU's UI changed and why reinstalling it doesnt fix anything. Perhaps my BIOS never allowed me to reduce the CPU multipliers and the old version of Intel XTU that i had was able to do it, but this was "fixed" by the update i downloaded.

Thats just my theory at any rate, I have no idea if that is true. I have tried asking on multiple tech forums, but nobody seems to have the slightest clue why i am suddenly not able to reduce my CPU multipliers after this windows update.

I cannot do a system restore as windows did not save a restore point before the update for some reason, and whatever update i downloaded is not listed in the list of installed updates or programs.

Can anyone help?

Edit : Nobody has any clue? Really?

1
  • Nobody has any clue? Really?
    – Question
    Jan 3, 2017 at 23:40

0

You must log in to answer this question.

Browse other questions tagged .