I just installed Windows XP, which is nothing new for me - I've done it at least 20 times now, using the same installation disk each time. However, I ran into quite a unique problem this time. The hard drive that contains the OS (Local Disk) is mounting as E: by default, leaving C: non-existant, which messes up installation files since they try to install to C:\filepath\program but C: doesn't exist. How do I tell it to mount Local Disk as C: by default?


Taken from https://support.microsoft.com/en-us/kb/223188

  1. Make a full system backup of the computer and system state.
  2. Log on as an Administrator.
  3. Start Regedt32.exe.
  4. Go to the following registry key:
  6. Click MountedDevices.
  7. On the Security menu, click Permissions.
  8. Verify that Administrators have full control. Change this back when you are finished with these steps.
  9. Quit Regedt32.exe, and then start Regedit.exe.
  10. Locate the following registry key: HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices
  11. Find the drive letter you want to change to (new). Look for "\DosDevices\C:".
  12. Right-click \DosDevices\C:, and then click Rename.

Note You must use Regedit instead of Regedt32 to rename this registry key. Rename it to an unused drive letter "\DosDevices\Z:".

This frees up drive letter C.

  1. Find the drive letter you want changed. Look for "\DosDevices\D:".

  2. Right-click \DosDevices\D:, and then click Rename.

  3. Rename it to the appropriate (new) drive letter "\DosDevices\C:".
  4. Click the value for \DosDevices\Z:, click Rename, and then name it back to "\DosDevices\D:".
  5. Quit Regedit, and then start Regedt32.
  6. Change the permissions back to the previous setting for Administrators (this should probably be Read Only).
  7. Restart the computer.

If you don't mind having two drive letters in use, you can also add C: as an alias for E:. The driver letter dialog in diskmgmt.msc not only has a Change drive letter option, but also a Add drive letter.

The benefit would be that existing software installations on E: do not break by the rename.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.