1

Today I tried installing a Virtual XP and Windows 7 PC on my computer using Oracle VirtualBox. I downloaded ISOs for Windows XP and Windows 7, and tried setting up Windows XP. Some files apparently were corrupted so I decided to restart my PC.

(In hindsight, I should have scanned the files for viruses, I deleted them from my computer since I thought that they were useless and I needed to get other versions)

When it starts back up, I'm greeted with this

The same goes for the taskbar and inside folders.

I can't see any of the icons or images, just the file names.

The first thing I tried to do was to reboot it in Safe Mode, but it didn't work. I tried rebuilding the icon cache, but it didn't work either.

My friend suggested enabling and disabling tablet mode.

Unfortunately, the option for enabling/disabling tablet mode was grayed out for me, so I couldn't do that.

He also suggested unplugging both my monitors and my Cintiq (which is a drawing tablet), no luck there either.

I scanned my computer with Malware Bytes but no threats were found on my computer.

I also tried doing the "SFC /scannow" comamnd in the command prompt, but it said that it found nothing wrong.

The two other questions asked on this website that I could find weren't much help for me either, one of them was a duplicate and the other suggested that I disable tablet mode, which really didn't help for me.

To anyone who can help me with this problem, thank you in advance.

EDIT

IconCache.db is nowhere to be found in my Local folder in Appdata. I tried to recreate it, delete it, then restart my PC. Nothing changed. I also went to 'C:\Users[username]\AppData\Local\Microsoft\Windows\Explorer' and deleted all the iconcache and thumbcache files then restarted my PC. That didn't solve the problem. I also forgot to mention that I use Windows 10.

EDIT 2 I tried using System Restore to reset my PC to a point before I installed my Virtual Machine, which was about a week ago. Sadly, that didn't help. I think there may be a problem within my files.

  • Do you have show desktop icons enabled? If you right click-desktop and go to view? – Dylan Rz Dec 19 '16 at 8:50
  • Yes I've tried that, I unchecked and checked "Show desktop icons" but nothing happened. Another thing is that I can view everything fine when I try to upload files on websites like Imgur or Mediafire – delatoid Dec 19 '16 at 19:25
1

If everything in this thread fails i would suggest your run an elevated command prompt and type: DISM /Online /Cleanup-Image /CheckHealth

now i know you said you rebuilt cache, i am not sure how or what method or even if the method provided by Arthur Kamande , Here is a batch file that will automate it for you, it might not be useful for you but can be for others if they face same issue .

  • I've tried your command but all that comes up is "No component store corruption detected" – delatoid Dec 19 '16 at 19:22
  • The method I also used for rebuilding my icon cache was that batch file, sorry for not making it clear in my question – delatoid Dec 19 '16 at 19:23
0

It seems like the only way I could fix this problem was resetting my computer.

I went to settings > update & security > recovery > advanced startup

I chose the option to keep all my files and I let my computer reset.

Thank you to those who helped me out and hopefully someone get this issue again.

-1

It could be that your icon cache is the issue . What I was thinking is that you can try to reset your icon cache you can try to rebuild it by going to this path C:\Users(Your User Name)\AppData\Local once there you can delete IconCache.db file. restart your machine it will recreate your icons.

  • OP has already stated that he tried to rebuild the icon cache / – Elie Dec 19 '16 at 9:04
  • Have you tried system restore it helps resolve some types of issues. – arthur kamande Dec 19 '16 at 9:40
  • I tried restoring it to a point before I installed my VM, which was about a week ago. That didn't help, my icons and thumbnails are still missing. – delatoid Dec 20 '16 at 6:00
-1

I had the same problem and I looked it up and I found a link that really helped me. It was a tutorial on how to fix this in windows 10. All you need to do is open up registry editor by doing Win Key + R and then typing:

regedit

Navigate to:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer

Find the one under that category labelled as Shell Icons. Then all you need to do is right click it, and rename it or delete it. Either or will fix the problem.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.