2

I asked a question yesterday about AFS and Fedora, and from the answer given to that question I now understand why following the guide I was following online did not work.

I have now started again and am attempting to install OpenAFS on a Fedora 24 system.

I am reading this page of the installation manual: http://docs.openafs.org/QuickStartUnix/HDRWQ143.html

I obtained the packages:

openafs, openafs-server, openafs-client and openafs-krb5 packages, along with an kmod-openafs package

by doing the following:

That seems to have worked...

I am now confused by the following lines in the installation guide:

You can find the version of your current kernel by running

# uname -r
2.6.20-1.2933.fc6

Once downloaded, the packages may be installed with the rpm command

# rpm -U openafs-* openafs-client-* openafs-server-* openafs-krb5-* kmod-openafs-*

For me, uname -r produces: 4.8.14-200.fc24.x86_64

I don't understand where I am supposed to obtain these rpm packages from. And so I am now totally stuck again.

2

RPMs are available from the OpenAFS web site

But as I see, there are no RPMs on their site (only SRPM). You can also rebuild them on your own:

wget http://openafs.org/dl/openafs/1.6.20.1/openafs-1.6.20.1-1.src.rpm
rpmbuild --rebuild openafs-1.6.20.1-1.src.rpm

you will need to download dependencies, but then you will get the RPMS in ~/rpmbuild/RPMS/*.

But ... you should be good with doing

dnf install openafs openafs-server openafs-client openafs-krb5 kmod-openafs

because in this case, dnf will download the RPM packages and install them for you (from the copr repository, you already enabled).

|improve this answer|||||
  • Okay, so I already have the RPMs then? Can you give me some hints on what to do next? I'm reading subsequent sections of the install guide but I just don't quite understand it. I have created the file /usr/vice/etc/CellServDB – user3728501 Dec 19 '16 at 18:19
  • It is not clear what does not work for you nor what are you trying to achieve. The installation should be complete. The other parts are configuration which widely depends on your use case. – Jakuje Dec 19 '16 at 19:57
  • I've tried to start the service and I see this error : modprobe: FATAL: Module openafs not found in directory /lib/modules/4.8.14-200.fc24.x86_64 – user3728501 Dec 19 '16 at 20:03
  • I'm not sure what to do to get the right module in that directory, however. – user3728501 Dec 19 '16 at 20:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.