0

I installed MAMP 4.0.6 and it works fine, but I want to use symfony and I need to use php in command line. But when I use it, I have :

php -v

dyld: Library not loaded: /Applications/MAMP/Library/lib/libcurl.4.dylib

Referenced from: /Applications/MAMP/bin/php/php7.0.12/bin/php

Reason: Incompatible library version: php requires version 9.0.0 or later, but libcurl.4.dylib provides version 7.0.0

I just reinstall the 7.50.3 with this tutorial : http://dev.soup.io/post/56438473/If-youre-using-MAMP-and-doing-something

Any idea ?

0

Install Newer libcurl Or Older MAMP.

A comment on this question indicates that libcurl.dylib is a macOS component, and if you want a newer version of you'll need to resort to macports.org or brew.sh.

The other option is to install an older version of MAMP that works with the older version of libcurl.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.