0

I have an openVPN server listening on the normal port, and I'm trying to use TunnelBlick to connect to the server from my apple laptop. When I was in the local network I was able to successfully connect to the server, but away from home I cannot connect to the server with TunnelBlick. I just get "Waiting for server response..." and a timer.

My server config is:

local 192.168.1.139
port 1194
proto udp
dev tun
sndbuf 0
rcvbuf 0
ca ca.crt
cert server.crt
key server.key
dh dh.pem
tls-auth ta.key 0
topology subnet
server 10.8.0.0 255.255.255.0
ifconfig-pool-persist ipp.txt
push "redirect-gateway def1 bypass-dhcp"
push "dhcp-option DNS 8.8.8.8"
push "dhcp-option DNS 8.8.4.4"
keepalive 10 120
cipher AES-256-CBC
comp-lzo
user nobody
group nogroup
persist-key
persist-tun
status openvpn-status.log
verb 3
crl-verify crl.pem

That IP is port forwarded in my router, and I can see that my client is trying to connect to the server with iftop on the server, so I think that openVPN is not accepting the connection? I have tried to google my issue and I haven't found anything relevant. I am new to openVPN and would like to get this figured out if possible.

2
  • You say you see the incoming connections with iftop. Do you see anything at all in the OpenVPN logs? Maybe bump the server up to verb 4 for more details in the logs. If you aren't seeing anything in the lots at all on the server, that probably means there is a firewall issue. Either on your host, or the router.
    – Zoredache
    Dec 19, 2016 at 22:10
  • I think that the issue is with the network configuration... I may have worked it out now... Dec 19, 2016 at 22:11

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.