7

I have a PC running Windows 10 and 2x touchscreen monitors. Ive set up the 2nd (right-hand) one to extend from my primary desktop but i can only get the touchscreen to work properly on screen 1. If i touch the 2nd screen the mouse just moves on screen one. This at least proves that its seeing both screens.

How do I set it up to see both touchscreens?

Any help would be much appreciated. :

5
  • I don't have a dual-touch screen setup to test on, but have you checked out the Tablet PC section of your Settings program? That's where touch-screen was set up on previous versions of Windows. Dec 20 '16 at 0:02
  • 4
    And to the person who voted to close this, by what definition in this green earth do you claim that it is unclear what is being asked? Yes, the language isn't the most clear, but based on reading the entire post it is VERY clear @Cornwall wants to be able to used touch on BOTH screens with the control on each screen reporting its correct position to the OS. Dec 20 '16 at 0:04
  • Thanks for the info @music2myear. I tried to force the PC to use tablet mode to see if this helped but no luck. Also tried to play around with the settings in the Tablet PC menu but it hasn't helped as yet. Also swapped around the primary display just to see if it was only favouring on screen but no luck. Wondering whether it would even support 2x touchscreens in the first place. with an extended desktop.
    – Cornwall
    Dec 20 '16 at 0:12
  • "Tablet Mode" will not be what you're looking for. But in the Tablet PC Settings in previous versions of windows there was a place to essentially calibrate your touch screens, and this would also allow you to tell your computer which screen was actually touch, or which screen touch input on that screen should show as input on. I'm trying to confirm where these settings went in Win10, but haven't found it yet. Dec 20 '16 at 0:22
6

USE a litte batch file : cmd /C multidigimon -touch

3
  • Can you explain what this does or how it does it?
    – bertieb
    Mar 21 '18 at 20:48
  • 1
    Thanks, this is much faster than going through the control panel and Tablet PC settings. Running multidigimon -touch from the start menu is efficient.
    – Fls'Zen
    May 1 '18 at 13:56
  • This was actually the only way I could get two touch displays correctly enabled, even after resetting calibration data on both displays. Nov 28 at 17:41
4

Issue Solved:-

Searched Tablet PC Settings in the Task Menu. Under the Display Tab, selected Setup under the Configure Title. This them prompts you to select the screens which you are using for touch screens. You simply tap on each display and boom, you can use both displays perfectly.

Thanks all for your help.

Not the answer you're looking for? Browse other questions tagged or ask your own question.