1

I'm using Fedora.

I don't know why my NTFS (/dev/sda3) partition is changed to "Unknown". I can't read this partition. My important files are located in there and I have to change it back to ntfs without losing data. enter image description here Any helps would be great appreciated.

P.S:

I think this problem occurred since I reformatted /boot/efi partition in /dev/sda1

UPDATE

I also tried to READ-ONLY /dev/sda3 :

sudo mount -r -t ntfs-3g /dev/sda3 /mnt/ -o force

But it returns this error :

NTFS signature is missing.
Failed to mount '/dev/sda3': Invalid argument
The device '/dev/sda3' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?

UPDATE 2

I also ran test disk :

sudo testdisk /dev/sda3

And testdisk says :

Partition sector doesn't have the endmark 0xAA55

And after testdisk Analyse :

The following partition can't be recovered:
     Partition               Start        End    Size in sectors
>  HPFS - NTFS          31779 193 31 47669  65 12  255264768
  • Is this your Windows boot partition? If you didn't shut it down clean, it'll cause problems. – Ravenix Dec 20 '16 at 9:35
  • No, It was my ` D:\ ` partition on Windows. – Hamed Kamrava Dec 20 '16 at 9:38
  • When you boot to Windows, is it accessible? – Ravenix Dec 20 '16 at 9:40
  • /dev/sda2 is my Windows 10 partition itself. I can't boot into that but I can read this partition data in Fedora – Hamed Kamrava Dec 20 '16 at 9:43
  • Was D:\ encrypted or anything unusual like that? – Hydraxan14 Dec 20 '16 at 17:43
0

Force NTFS Read-Only Mount

Perhaps you can try forcibly mounting the partition as ntfs in read-only mode?

mount -r -t ntfs-3g /dev/sda3 /media/mymounteddrive -o force

  • Not working! First post has been updated... – Hamed Kamrava Dec 21 '16 at 5:36
0

This solution is for an older version of Linux, but the same concept should translate to the same method that can be applied to newer versions as well.

However, from my understanding, it may have been possible that the Master Boot Record has been overwritten or corrupted in some kind of way.

If you have the ability to do so, first attempt to try and restore the MBR through Linux.

However, this could possibly be easily fixed by using >sfdisk

sfdisk /dev/sda -i -c 1 07

You may also want to use TestDisk to detect any issues

For Fedora specifically the following steps may help.

With Fedora CD Boot your computer with the first CD of Fedora in your CD drive (You have to enable your PC to boot from the cdrom, which you can set in the BIOS settings). At the installation boot prompt that you get, enter the following command:

boot: linux rescue

Press Enter. The installer will ask you a few questions like the language you would like to use, the type of keyboard etc. Then, if you have linux previously installed on your machine, the Fedora installer will automatically detect it and mount it in the /mnt/sysimage directory. Once the linux partition is mounted, you are dropped into the command shell prompt. The next step is to make your newly mounted directory the root (or parent) directory. This you do by running the chroot command as follows:

# chroot /mnt/sysimage
# _

Make sure to restore GRUB:

# grub-install /dev/hda
  • The question clearly shows that the NTFS signature is missing from the partition. The MBR has nothing to do with it nor does GRUB. – Andrea Lazzarotto Dec 24 '16 at 17:09
  • @AndreaLazzarotto Not working. See the first post – Hamed Kamrava Dec 24 '16 at 17:44
  • @HamedKamrava why are you mentioning me? I am not the author of this wrong answer. – Andrea Lazzarotto Dec 24 '16 at 20:04
  • @AndreaLazzarotto Oh yeah :)) sorry... – Hamed Kamrava Dec 25 '16 at 6:38
  • Not working. See the first post – Hamed Kamrava Dec 25 '16 at 6:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.