4

I habitually use RDP to access my desktop, but have enountered some problems after moving and setting up my computer on a new network.

When using the RDP app on my android phone (on 4G so not same network), I am able to connect to the computer. However, when I try to connect with either of my laptops, it stays at "Initiating remote connection" without opening the login prompt.

I used portqry to check if port 3389 is open for RDP. When I do this on the computer I try to remote into is comes back as "listening", but when I try with the laptop on an other network it comes back as "filtered"

This made me think there is a firewall issue, but the strange thing is that I can successfully connect with my my phone. I have tried connecting with my laptop while going online using the same phone as a mobile hotspot, but it still doesn't work. Therefore it seems to me that the problem must be on the laptops I try connect with.

I haven't had the experience that I am able to connect with some devices, but not others. Do any of you have suggestions for what I could try?

My desktop that I am trying to remote into is running Win 10 pro The laptops run Win 10 pro and Win 7 Pro The phone is running Android (only device I have been able to connect)

Things I have tried so far based on google search

  • made sure I have remote desktop enabled and setup port forwarding on the local network (this should be correctly set up given I can connect with my phone)

  • use mstsc programs located in both System 32 and SysWOW64

EDIT: The issue turned out to be the firewall on the laptops I was trying to use to connect with (two different work laptops)

  • Do you have your port forwarding rule setup to allow any IP addresses to come in through port 3389 or only from specific IP address(es). – n8te Dec 22 '16 at 10:52
  • The Router is Cisco EPC3940 ADL – Jon Dec 22 '16 at 10:55
  • As far as I can see in my router settings there is no restriction on which IP addresses can connect. Under port forwarding I have only entered the port to open and which local IP address it should be forwarded to. – Jon Dec 22 '16 at 10:57
  • How about the firewall on the destination PC? Is port 3389 open for all incoming connections, or only specific IP address(es)? That "filtered" you got back from portqry is telling you that either a firewall is blocking it or a router rule. It doesn't sound like your port forwarding could be the problem on the router. Sounds like a firewall is blocking you. – n8te Dec 22 '16 at 11:01
  • If I were you I would try turn off the firewall real quick on the destination PC and try to RDP in. If it's still blocked, try turning off your firewall on the laptop and then try to RDP in. Just one by one start eliminating what could be the possible cause. – n8te Dec 22 '16 at 11:04
0

Given that your phone is not in the same network as the rest and coming from the outside and it works rules out a lot.

RDP is working, so the only thing this could be, is that you try to connect to the OUTSIDE port of your network while being on the INSIDE.

To say it bluntly, if you are inside the house and the door is closed, you cannot touch the outside of the front door.

Some routers allow a loopback connection, but the Cisco does not.

So for this to work, make sure you connect to the internal IP address, not the external one.

0

Appears the problem was due to firewalls on the laptops I was initially trying to connect, blocking the outgoing RDP request. Using a regular non-work computer worked, as well as other mobile devices.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.