0

My core issue is that I'm trying to get my HTPC to start X on the TV even when the TV is off when the computer starts. This requires a (small) amount of mucking around with /etc/X11/xorg.conf, but in order to actually do it, I need a basic xorg.conf to work off.

So I run "Xorg -configure", and I get this:

X.Org X Server 1.18.4
Release Date: 2016-07-19
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.4.0-45-generic x86_64 Ubuntu
Current Operating System: Linux tv 4.4.0-57-generic #78-Ubuntu SMP Fri Dec 9 23:50:32 UTC 2016 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.4.0-57-generic root=/dev/mapper/os-root ro quiet splash vt.handoff=7
Build Date: 02 November 2016  10:06:10PM
xorg-server 2:1.18.4-0ubuntu0.2 (For technical support please see http://www.ubuntu.com/support) 
Current version of pixman: 0.33.6
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Dec 23 10:21:09 2016
List of video drivers:
        amdgpu
        nouveau
        qxl
        radeon
        vmware
        modesetting
        vesa
        fbdev
        ati
No devices to configure.  Configuration failed.
(EE) Server terminated with error (2). Closing log file.

/var/log/Xorg.0.log has:

X.Org X Server 1.18.4
Release Date: 2016-07-19
[  2216.851] X Protocol Version 11, Revision 0
[  2216.851] Build Operating System: Linux 4.4.0-45-generic x86_64 Ubuntu
[  2216.851] Current Operating System: Linux tv 4.4.0-57-generic #78-Ubuntu SMP Fri Dec 9 23:50:32 UTC 2016 x86_64
[  2216.851] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.4.0-57-generic root=/dev/mapper/os-root ro quiet splash vt.handoff=7
[  2216.851] Build Date: 02 November 2016  10:06:10PM
[  2216.851] xorg-server 2:1.18.4-0ubuntu0.2 (For technical support please see http://www.ubuntu.com/support) 
[  2216.851] Current version of pixman: 0.33.6
[  2216.851]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[  2216.851] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  2216.852] (==) Log file: "/var/log/Xorg.0.log", Time: Fri Dec 23 10:21:09 2016
[  2216.852] (II) Loader magic: 0x55ad38871dc0
[  2216.852] (II) Module ABI versions:
[  2216.852]    X.Org ANSI C Emulation: 0.4
[  2216.852]    X.Org Video Driver: 20.0
[  2216.852]    X.Org XInput driver : 22.1
[  2216.852]    X.Org Server Extension : 9.0
[  2216.853] (--) using VT number 2

[  2216.853] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[  2216.853] (II) xfree86: Adding drm device (/dev/dri/card0)
[  2216.855] (--) PCI:*(0:0:2:0) 8086:2e22:8086:0028 rev 3, Mem @ 0xd4000000/4194304, 0xc0000000/268435456, I/O @ 0x0000f1a0/8
[  2216.855] (--) PCI: (0:0:2:1) 8086:2e23:8086:0028 rev 3, Mem @ 0xd4400000/1048576
[  2216.855] (--) PCI: (0:4:4:0) 4444:0016:0070:8801 rev 1, Mem @ 0xd0000000/67108864
[  2216.856] List of video drivers:
[  2216.856]    amdgpu
[  2216.856]    nouveau
[  2216.856]    qxl
[  2216.856]    radeon
[  2216.856]    vmware
[  2216.856]    modesetting
[  2216.856]    vesa
[  2216.856]    fbdev
[  2216.856]    ati
[  2216.856] (II) LoadModule: "amdgpu"
[  2216.856] (II) Loading /usr/lib/xorg/modules/drivers/amdgpu_drv.so
[  2216.857] (II) Module amdgpu: vendor="X.Org Foundation"
[  2216.857]    compiled for 1.18.3, module version = 1.1.0
[  2216.857]    Module class: X.Org Video Driver
[  2216.857]    ABI class: X.Org Video Driver, version 20.0
[  2216.857] (II) LoadModule: "nouveau"
[  2216.857] (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so
[  2216.857] (II) Module nouveau: vendor="X.Org Foundation"
[  2216.857]    compiled for 1.18.1, module version = 1.0.12
[  2216.857]    Module class: X.Org Video Driver
[  2216.857]    ABI class: X.Org Video Driver, version 20.0
[  2216.857] (II) LoadModule: "qxl"
[  2216.857] (II) Loading /usr/lib/xorg/modules/drivers/qxl_drv.so
[  2216.857] (II) Module qxl: vendor="X.Org Foundation"
[  2216.857]    compiled for 1.18.1, module version = 0.1.4
[  2216.857]    Module class: X.Org Video Driver
[  2216.857]    ABI class: X.Org Video Driver, version 20.0
[  2216.857] (II) LoadModule: "radeon"
[  2216.857] (II) Loading /usr/lib/xorg/modules/drivers/radeon_drv.so
[  2216.858] (II) Module radeon: vendor="X.Org Foundation"
[  2216.858]    compiled for 1.18.3, module version = 7.7.0
[  2216.858]    Module class: X.Org Video Driver
[  2216.858]    ABI class: X.Org Video Driver, version 20.0
[  2216.858] (II) LoadModule: "vmware"
[  2216.858] (II) Loading /usr/lib/xorg/modules/drivers/vmware_drv.so
[  2216.872] (II) Module vmware: vendor="X.Org Foundation"
[  2216.872]    compiled for 1.18.1, module version = 13.1.0
[  2216.872]    Module class: X.Org Video Driver
[  2216.872]    ABI class: X.Org Video Driver, version 20.0
[  2216.872] (II) LoadModule: "modesetting"
[  2216.872] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[  2216.872] (II) Module modesetting: vendor="X.Org Foundation"
[  2216.872]    compiled for 1.18.4, module version = 1.18.4
[  2216.872]    Module class: X.Org Video Driver
[  2216.872]    ABI class: X.Org Video Driver, version 20.0
[  2216.872] (II) LoadModule: "vesa"
[  2216.872] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[  2216.872] (II) Module vesa: vendor="X.Org Foundation"
[  2216.872]    compiled for 1.18.1, module version = 2.3.4
[  2216.872]    Module class: X.Org Video Driver
[  2216.872]    ABI class: X.Org Video Driver, version 20.0
[  2216.872] (II) LoadModule: "fbdev"
[  2216.872] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[  2216.872] (II) Module fbdev: vendor="X.Org Foundation"
[  2216.872]    compiled for 1.18.1, module version = 0.4.4
[  2216.872]    Module class: X.Org Video Driver
[  2216.872]    ABI class: X.Org Video Driver, version 20.0
[  2216.872] (II) LoadModule: "ati"
[  2216.872] (II) Loading /usr/lib/xorg/modules/drivers/ati_drv.so
[  2216.872] (II) Module ati: vendor="X.Org Foundation"
[  2216.872]    compiled for 1.18.3, module version = 7.7.0
[  2216.872]    Module class: X.Org Video Driver
[  2216.872]    ABI class: X.Org Video Driver, version 20.0
[  2216.873] (II) modeset(G0): using drv /dev/dri/card0
[  2216.873] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[  2216.873] (WW) Falling back to old probe method for vesa
[  2216.873] (WW) Falling back to old probe method for fbdev
[  2216.873] No devices to configure.  Configuration failed.

Strangely, when I just run xorg, everything works just fine:

[  2649.044] 
X.Org X Server 1.18.4
Release Date: 2016-07-19
[  2649.044] X Protocol Version 11, Revision 0
[  2649.044] Build Operating System: Linux 4.4.0-45-generic x86_64 Ubuntu
[  2649.044] Current Operating System: Linux tv 4.4.0-57-generic #78-Ubuntu SMP Fri Dec 9 23:50:32 UTC 2016 x86_64
[  2649.044] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.4.0-57-generic root=/dev/mapper/os-root ro quiet splash vt.handoff=7
[  2649.044] Build Date: 02 November 2016  10:06:10PM
[  2649.044] xorg-server 2:1.18.4-0ubuntu0.2 (For technical support please see http://www.ubuntu.com/support) 
[  2649.044] Current version of pixman: 0.33.6
[  2649.044]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[  2649.044] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  2649.044] (==) Log file: "/var/log/Xorg.0.log", Time: Fri Dec 23 10:28:21 2016
[  2649.044] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  2649.045] (==) No Layout section.  Using the first Screen section.
[  2649.045] (==) No screen section available. Using defaults.
[  2649.045] (**) |-->Screen "Default Screen Section" (0)
[  2649.045] (**) |   |-->Monitor "<default monitor>"
[  2649.045] (==) No monitor specified for screen "Default Screen Section".
        Using a default monitor configuration.
[  2649.045] (==) Automatically adding devices
[  2649.045] (==) Automatically enabling devices
[  2649.045] (==) Automatically adding GPU devices
[  2649.045] (==) Max clients allowed: 256, resource mask: 0x1fffff
[  2649.045] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[  2649.045]    Entry deleted from font path.
[  2649.045] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[  2649.045]    Entry deleted from font path.
[  2649.045] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[  2649.045]    Entry deleted from font path.
[  2649.045] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[  2649.045]    Entry deleted from font path.
[  2649.045] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[  2649.045]    Entry deleted from font path.
[  2649.045] (==) FontPath set to:
        /usr/share/fonts/X11/misc,
        /usr/share/fonts/X11/Type1,
        built-ins
[  2649.045] (==) ModulePath set to "/usr/lib/x86_64-linux-gnu/xorg/extra-modules,/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
[  2649.045] (II) The server relies on udev to provide the list of input devices.
        If no devices become available, reconfigure udev or disable AutoAddDevices.
[  2649.045] (II) Loader magic: 0x557c879f6dc0
[  2649.045] (II) Module ABI versions:
[  2649.045]    X.Org ANSI C Emulation: 0.4
[  2649.045]    X.Org Video Driver: 20.0
[  2649.045]    X.Org XInput driver : 22.1
[  2649.045]    X.Org Server Extension : 9.0
[  2649.046] (--) using VT number 2

[  2649.046] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[  2649.047] (II) xfree86: Adding drm device (/dev/dri/card0)
[  2649.049] (--) PCI:*(0:0:2:0) 8086:2e22:8086:0028 rev 3, Mem @ 0xd4000000/4194304, 0xc0000000/268435456, I/O @ 0x0000f1a0/8
[  2649.049] (--) PCI: (0:0:2:1) 8086:2e23:8086:0028 rev 3, Mem @ 0xd4400000/1048576
[  2649.049] (--) PCI: (0:4:4:0) 4444:0016:0070:8801 rev 1, Mem @ 0xd0000000/67108864
[  2649.049] (II) LoadModule: "glx"
[  2649.049] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[  2649.050] (II) Module glx: vendor="X.Org Foundation"
[  2649.050]    compiled for 1.18.4, module version = 1.0.0
[  2649.050]    ABI class: X.Org Server Extension, version 9.0
[  2649.050] (==) AIGLX enabled
[  2649.050] (==) Matched intel as autoconfigured driver 0
[  2649.050] (==) Matched intel as autoconfigured driver 1
[  2649.050] (==) Matched modesetting as autoconfigured driver 2
[  2649.050] (==) Matched fbdev as autoconfigured driver 3
[  2649.050] (==) Matched vesa as autoconfigured driver 4
[  2649.050] (==) Assigned the driver to the xf86ConfigLayout
[  2649.050] (II) LoadModule: "intel"
[  2649.051] (WW) Warning, couldn't open module intel
[  2649.051] (II) UnloadModule: "intel"
[  2649.051] (II) Unloading intel
[  2649.051] (EE) Failed to load module "intel" (module does not exist, 0)
[  2649.051] (II) LoadModule: "modesetting"
[  2649.051] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[  2649.051] (II) Module modesetting: vendor="X.Org Foundation"
[  2649.051]    compiled for 1.18.4, module version = 1.18.4
[  2649.051]    Module class: X.Org Video Driver
[  2649.051]    ABI class: X.Org Video Driver, version 20.0
[  2649.051] (II) LoadModule: "fbdev"
[  2649.051] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[  2649.051] (II) Module fbdev: vendor="X.Org Foundation"
[  2649.051]    compiled for 1.18.1, module version = 0.4.4
[  2649.051]    Module class: X.Org Video Driver
[  2649.051]    ABI class: X.Org Video Driver, version 20.0
[  2649.051] (II) LoadModule: "vesa"
[  2649.051] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[  2649.051] (II) Module vesa: vendor="X.Org Foundation"
[  2649.052]    compiled for 1.18.1, module version = 2.3.4
[  2649.052]    Module class: X.Org Video Driver
[  2649.052]    ABI class: X.Org Video Driver, version 20.0
[  2649.052] (==) Matched intel as autoconfigured driver 0
[  2649.052] (==) Matched intel as autoconfigured driver 1
[  2649.052] (==) Matched modesetting as autoconfigured driver 2
[  2649.052] (==) Matched fbdev as autoconfigured driver 3
[  2649.052] (==) Matched vesa as autoconfigured driver 4
[  2649.052] (==) Assigned the driver to the xf86ConfigLayout
[  2649.052] (II) LoadModule: "intel"
[  2649.052] (WW) Warning, couldn't open module intel
[  2649.052] (II) UnloadModule: "intel"
[  2649.052] (II) Unloading intel
[  2649.052] (EE) Failed to load module "intel" (module does not exist, 0)
[  2649.052] (II) LoadModule: "modesetting"
[  2649.052] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[  2649.052] (II) Module modesetting: vendor="X.Org Foundation"
[  2649.052]    compiled for 1.18.4, module version = 1.18.4
[  2649.052]    Module class: X.Org Video Driver
[  2649.052]    ABI class: X.Org Video Driver, version 20.0
[  2649.052] (II) UnloadModule: "modesetting"
[  2649.052] (II) Unloading modesetting
[  2649.052] (II) Failed to load module "modesetting" (already loaded, 0)
[  2649.052] (II) LoadModule: "fbdev"
[  2649.052] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[  2649.052] (II) Module fbdev: vendor="X.Org Foundation"
[  2649.052]    compiled for 1.18.1, module version = 0.4.4
[  2649.052]    Module class: X.Org Video Driver
[  2649.052]    ABI class: X.Org Video Driver, version 20.0
[  2649.052] (II) UnloadModule: "fbdev"
[  2649.052] (II) Unloading fbdev
[  2649.052] (II) Failed to load module "fbdev" (already loaded, 0)
[  2649.052] (II) LoadModule: "vesa"
[  2649.053] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[  2649.053] (II) Module vesa: vendor="X.Org Foundation"
[  2649.053]    compiled for 1.18.1, module version = 2.3.4
[  2649.053]    Module class: X.Org Video Driver
[  2649.053]    ABI class: X.Org Video Driver, version 20.0
[  2649.053] (II) UnloadModule: "vesa"
[  2649.053] (II) Unloading vesa
[  2649.053] (II) Failed to load module "vesa" (already loaded, 0)
[  2649.053] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[  2649.053] (II) FBDEV: driver for framebuffer: fbdev
[  2649.053] (II) VESA: driver for VESA chipsets: vesa
[  2649.056] (II) modeset(0): using drv /dev/dri/card0
[  2649.056] (WW) Falling back to old probe method for modesetting
[  2649.056] (WW) Falling back to old probe method for fbdev
[  2649.056] (II) Loading sub module "fbdevhw"
[  2649.056] (II) LoadModule: "fbdevhw"
[  2649.056] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[  2649.056] (II) Module fbdevhw: vendor="X.Org Foundation"
[  2649.056]    compiled for 1.18.4, module version = 0.0.2
[  2649.056]    ABI class: X.Org Video Driver, version 20.0
[  2649.056] (WW) Falling back to old probe method for vesa
[  2649.056] (II) modeset(0): Creating default Display subsection in Screen section
        "Default Screen Section" for depth/fbbpp 24/32
[  2649.056] (==) modeset(0): Depth 24, (==) framebuffer bpp 32
[  2649.056] (==) modeset(0): RGB weight 888
[  2649.056] (==) modeset(0): Default visual is TrueColor
[  2649.056] (II) Loading sub module "glamoregl"
[  2649.056] (II) LoadModule: "glamoregl"
[  2649.056] (II) Loading /usr/lib/xorg/modules/libglamoregl.so
[  2649.061] (II) Module glamoregl: vendor="X.Org Foundation"
[  2649.061]    compiled for 1.18.4, module version = 1.0.0
[  2649.061]    ABI class: X.Org ANSI C Emulation, version 0.4
[  2649.061] (II) glamor: OpenGL accelerated X.org driver based.
[  2649.072] (II) glamor: EGL version 1.4 (DRI2):
[  2649.076] (II) modeset(0): glamor initialized
[  2649.096] (II) modeset(0): Output VGA-1 has no monitor section
[  2649.230] (II) modeset(0): Output HDMI-1 has no monitor section
[  2649.256] (II) modeset(0): Output DP-1 has no monitor section
[  2649.264] (II) modeset(0): Output HDMI-2 has no monitor section
[  2649.264] (II) modeset(0): Output DP-2 has no monitor section
[  2649.284] (II) modeset(0): EDID for output VGA-1
[  2649.418] (II) Quirked EDID physical size to 0x0 cm
[  2649.418] (II) modeset(0): EDID for output HDMI-1
[  2649.418] (II) modeset(0): Manufacturer: GSM  Model: 1  Serial#: 16843009
[  2649.418] (II) modeset(0): Year: 2011  Week: 1
[  2649.418] (II) modeset(0): EDID Version: 1.3
[  2649.418] (II) modeset(0): Digital Display Input
[  2649.418] (II) modeset(0): Indeterminate output size
[  2649.418] (II) modeset(0): Gamma: 2.20
[  2649.418] (II) modeset(0): No DPMS capabilities specified
[  2649.418] (II) modeset(0): Supported color encodings: RGB 4:4:4 YCrCb 4:4:4 
[  2649.418] (II) modeset(0): First detailed timing is preferred mode
[  2649.418] (II) modeset(0): redX: 0.640 redY: 0.330   greenX: 0.300 greenY: 0.600
[  2649.418] (II) modeset(0): blueX: 0.150 blueY: 0.060   whiteX: 0.312 whiteY: 0.329
[  2649.418] (II) modeset(0): Supported established timings:
[  2649.418] (II) modeset(0): 720x400@70Hz
[  2649.418] (II) modeset(0): 640x480@60Hz
[  2649.418] (II) modeset(0): 800x600@60Hz
[  2649.418] (II) modeset(0): 1024x768@60Hz
[  2649.418] (II) modeset(0): Manufacturer's mask: 0
[  2649.418] (II) modeset(0): Supported standard timings:
[  2649.418] (II) modeset(0): #0: hsize: 1152  vsize 864  refresh: 75  vid: 20337
[  2649.418] (II) modeset(0): #1: hsize: 1280  vsize 1024  refresh: 60  vid: 32897
[  2649.418] (II) modeset(0): Supported detailed timing:
[  2649.418] (II) modeset(0): clock: 148.5 MHz   Image Size:  160 x 90 mm
[  2649.418] (II) modeset(0): h_active: 1920  h_sync: 2008  h_sync_end 2052 h_blank_end 2200 h_border: 0
[  2649.418] (II) modeset(0): v_active: 1080  v_sync: 1084  v_sync_end 1089 v_blanking: 1125 v_border: 0
[  2649.418] (II) modeset(0): Supported detailed timing:
[  2649.418] (II) modeset(0): clock: 84.8 MHz   Image Size:  160 x 90 mm
[  2649.418] (II) modeset(0): h_active: 1360  h_sync: 1432  h_sync_end 1568 h_blank_end 1776 h_border: 0
[  2649.418] (II) modeset(0): v_active: 768  v_sync: 771  v_sync_end 776 v_blanking: 798 v_border: 0
[  2649.418] (II) modeset(0): Ranges: V min: 58 V max: 62 Hz, H min: 30 H max: 83 kHz, PixClock max 165 MHz
[  2649.418] (II) modeset(0): Monitor name: LG TV
[  2649.418] (II) modeset(0): Supported detailed timing:
[  2649.418] (II) modeset(0): clock: 74.2 MHz   Image Size:  160 x 90 mm
[  2649.418] (II) modeset(0): h_active: 1920  h_sync: 2008  h_sync_end 2052 h_blank_end 2200 h_border: 0
[  2649.418] (II) modeset(0): v_active: 540  v_sync: 542  v_sync_end 547 v_blanking: 562 v_border: 0
[  2649.418] (II) modeset(0): Supported detailed timing:
[  2649.418] (II) modeset(0): clock: 74.2 MHz   Image Size:  160 x 90 mm
[  2649.418] (II) modeset(0): h_active: 1280  h_sync: 1390  h_sync_end 1430 h_blank_end 1650 h_border: 0
[  2649.418] (II) modeset(0): v_active: 720  v_sync: 725  v_sync_end 730 v_blanking: 750 v_border: 0
[  2649.418] (II) modeset(0): Supported detailed timing:
[  2649.418] (II) modeset(0): clock: 148.5 MHz   Image Size:  160 x 90 mm
[  2649.418] (II) modeset(0): h_active: 1920  h_sync: 2008  h_sync_end 2052 h_blank_end 2200 h_border: 0
[  2649.418] (II) modeset(0): v_active: 1080  v_sync: 1084  v_sync_end 1089 v_blanking: 1125 v_border: 0
[  2649.418] (II) modeset(0): Supported detailed timing:
[  2649.418] (II) modeset(0): clock: 74.2 MHz   Image Size:  160 x 90 mm
[  2649.418] (II) modeset(0): h_active: 1280  h_sync: 1720  h_sync_end 1760 h_blank_end 1980 h_border: 0
[  2649.418] (II) modeset(0): v_active: 720  v_sync: 725  v_sync_end 730 v_blanking: 750 v_border: 0
[  2649.418] (II) modeset(0): Number of EDID sections to follow: 1
[  2649.418] (II) modeset(0): EDID (in hex):
[  2649.418] (II) modeset(0):   00ffffffffffff001e6d010001010101
[  2649.418] (II) modeset(0):   01150103801009780aee91a3544c9926
[  2649.418] (II) modeset(0):   0f5054a10800714f8180010101010101
[  2649.418] (II) modeset(0):   010101010101023a801871382d40582c
[  2649.418] (II) modeset(0):   4500a05a0000001e1b2150a051001e30
[  2649.418] (II) modeset(0):   48883500a05a0000001c000000fd003a
[  2649.418] (II) modeset(0):   3e1e5310000a202020202020000000fc
[  2649.418] (II) modeset(0):   004c472054560a2020202020202001e2
[  2649.418] (II) modeset(0):   020326f14e101f841305140302122021
[  2649.418] (II) modeset(0):   2215012615075009570767030c003000
[  2649.418] (II) modeset(0):   b82de3050301011d8018711c1620582c
[  2649.419] (II) modeset(0):   2500a05a0000009e011d007251d01e20
[  2649.419] (II) modeset(0):   6e285500a05a0000001e023a80187138
[  2649.419] (II) modeset(0):   2d40582c4500a05a0000001e011d00bc
[  2649.419] (II) modeset(0):   52d01e20b8285540a05a0000001e0000
[  2649.419] (II) modeset(0):   00000000000000000000000000000079
[  2649.419] (--) modeset(0): HDMI max TMDS frequency 225000KHz
[  2649.419] (II) modeset(0): Printing probed modes for output HDMI-1
[  2649.419] (II) modeset(0): Modeline "1920x1080"x60.0  148.50  1920 

Snipped due to being too long.

Is there an easy way to get a default working xorg.conf so I can start editing it? I just want to add the modeline and force use of HDMI-1.

  • You are using the modesetting driver, which does everything inside the kernel, so X probing fails. Also, I don't think the modesetting driver always works for TV. What's your grpahics card? Output of lspci for the graphics card? – dirkt Dec 24 '16 at 9:39
  • Actually, as it turns out, while probing doesn't work, the driver itself works just fine. I guess whether it works or not depends on the TV, and mine seems to do okay, so long as it is turned on when the computer starts. – Shachar Shemesh Dec 24 '16 at 17:22
2

I managed to run the probe by replacing the driver with the i9xx driver, but as it turns out, the probing wasn't even necessary. Unlike what I though, I did not need the whole tree of sections (monitor, screen and device). Just the monitor section is enough:

The following xorg.conf did the trick for me:

Section "Monitor"
        Identifier "HDMI-1"
        VendorName "LG"
        Modeline "forced" 148.50  1920 2008 2052 2200  1080 1084 1089 1125 +hsync +vsync
        Option "Primary" "true"
        Option "PreferredMode" "forced"
        Option "Enable" "true"
        Option "IgnoreEDID"
EndSection

The modeline is taken, almost verbatim, from the Xorg.0.log of a successful run (i.e. - one where the TV is on).

  • "I managed to run the probe by replacing the driver with the i9xx driver" - can you elaborate on how exactly you did that? – Paul Aug 25 '17 at 16:46
  • @Paul, I'm sorry, I simply don't remember. – Shachar Shemesh Aug 26 '17 at 5:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.