0

My parents' laptop has a peculiar problem. It can't load any Yahoo sites (they are trying to access hk.yahoo.com). All that loads is text and links (i.e. images, videos, and stylesheets don't load):

At the beginning, all of the resources are pending (I'm trying Yahoo IE here instead of Yahoo HK).

Then, they all eventually time out.

The laptop has Windows 7. Every other site loads lightning fast, even heavier ones like Facebook.

This is what I've tried to no avail:

  • I tried loading the site in Chrome, FF, and IE 11 (all latest versions).
  • I tried accessing Yahoo on my phone on the same wifi network, and it redirects to its mobile site, but the same thing happens.
  • I ran ipconfig /release, /renew, and /flushdns.
  • I turned off all of the security settings in the IE internet settings (Custom level).
  • I cleared the cache, cookies, temp files, etc. via Chrome and IE, as well as going into the AppData folder.
  • I uninstalled FF.
  • I turned off the antivirus (Avira Free).
  • I checked the router admin page. Everything looks normal.
  • I tried using Google's public DNS (8.8.8.8 and 8.8.8.4).
  • I turned off the automatic proxy setting.
  • Restarted the computer.
  • Pinged www.hk.yahoo.com, www.yahoo.com, www.google.com, and 188.125.80.144 (Yahoo) in cmd - all are reachable.
  • Tried to load it in Chrome incognito mode.

I'm really stumped. Does anyone have any ideas? Maybe I'm missing something obvious. Just remember that every other site I've tried loads fine, and there are no obvious problems with the laptop.

0

If the same thing happens with both a laptop and a phone on the same wifi network, then it's either a router configuration problem or something with the ISP. Try temporarily disabling any firewall or security options in the router, if the problem persists then it's probably the ISP, in which case you'd need to contact their support.

  • Thanks, I don't have access to that laptop right now but I will look harder in the router settings and report back. – z.ky Dec 25 '16 at 13:18
0

I've seen this happen because of reduced path MTUs plus Path MTU Discovery black holes. Sometimes NAT gateways that fail to do MSS Clamping are part of the problem.

Try setting Windows' MTU for that interface to something low like 1300 and see if the problem goes away. If it does, try higher values until you find the highest value that works. If their broadband connection uses PPPoE, the magic value is likely 1492.

This is commonly reported as "Yahoo sites don't load but Google sites load fine", because Google intentionally negotiates a reduced TCP MSS to get around this kind of problem.

  • Thanks, I don't have access to that laptop right now but I will try this and report back. – z.ky Dec 25 '16 at 13:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.