3

I have two routers and two computers... I cant seem to be able to get the computers to see each other on the network.

  • Router1 (CenturyLink PK5001A) is also a modem and is connected to the internet.
  • Router2 (Linksys BEFSR41 v3.1) is connected to Router1.

  • PC1 is connected to Router1.

  • PC2 is connected to Router2.

  • PC1 (Windows 7) cannot find/see PC2 (Windows XP).

  • PC2 also cannot find/see PC1.

They both have the same WORKGROUP name which is "WORKGROUP".

What gives?

When they both are on the same router (Router1) they can see each other and share files fine.

And what I mean when I say "see each other" - as in when I go to "Network" and can see the other computer(s) and be able to click on them and view the shared folders.

For example:
On PC1 I'd like to be able to type in "\\PC2\MySharedFolder" and it navigate to MySharedFolder on PC2

enter image description here

[---------------SOLVED---------------]

Special thanks to Edward and Ramrod for their help. It turns out that the WAN port (the internet feed port) on Router2 (Linksys) CANNOT be configured to hold traffic with DHCP disabled - meaning the internet feed ethernet cable MUST BE PLUGGED into one of the 4 LAN ports, not the internet feed port (also known by everyone but me as the WAN port). Due to my ignorance it took me a while to catch on to this.

As soon as I plugged the internet feed ethernet cable into one of the 4 LAN ports on Router2 instead of the WAN port, the Router2 automatically configured itself as a Access Point/Bridge/Switch/idk and allowed Router1 to assign the IP addresses (192.168.0.x) and now all the computers can successfully see each other on the network. Kinda weak if you ask me, the WAN port should be able to be used as a LAN or WAN, whatever I choose.

Concerning this, I went ahead and bought a NETGEAR N300 which DOES ALLOW you to put the internet feed into the WAN port and configure it as an Access Point (which I guess intern treats the WAN port as a LAN port instead). This allows you to support 4 additional computers instead of just the 3 additional ones the Linksys could only support in this setup (since one HAD to be used for the internet feed).

  • 1
    Your second router need to have routing, DHCP, etc. disabled. Don't use it as a router, use it as a bridge. – Ron Maupin Dec 24 '16 at 21:47
  • also, you should define "see each other" – barlop Dec 24 '16 at 22:37
  • We need the router models to give you a better answer, and as mentioned - define what you mean by 'see' each other. There is likely little reason for router two to be configured as a router... likely it needs to be ran In access point mode with the connection from router 1s LAN connected to one of Router 2s LAN. – Ramrod Dec 25 '16 at 3:09
  • updated the question above. please see. thanks. – zdanman Dec 26 '16 at 14:37
2

The first basic thing you can do is bring up a commmand window as well as browsers for your individual router admin page. When say you know the IP address of PC1 by typing ipconfig into the CMD window you can see your IP address, and needless to say this needs to be on the same network range as all your other devices (routers and PC2) to see them unless you know how to setup that connection on the routers to "Route" from one network range to another.

This is for if the router2 is connected to router1 through the LAN ports on both machines.

most of your internal devices I would say are on the 192.168.1.0 range.
As a possible solution have the Router connected to the internet setup for DHCP with an IP address of 192.168.1.1 and a subnet of 255.255.255.0 . Check PC1 is connected with that address as the default route in the CMD window with ipconfig. Next in the admin page for router2 make sure it has the default route setup as 192.168.1.1 with its IP as 192.168.1.2. Lastly in PC2 you can try and type Ping to all three of those IP addressses to see if it completes successfully.

After all that is done and you still have issues it may be because you need to type a double \ at the beginning of the url PC2\MySharedFolder

I would like to clarify my solution is to put everything on the same network IP/subnet mask range, because I believe that is the only way Windows workgroup sharing will actuall work; but I may be wrong on that.

  • btw I did use double slashes however superuser editing removed them (corrected) – zdanman Dec 26 '16 at 3:29
  • so that i understand.... currently Router1 is setup as 192.168.0.1 which is the 'default gateway' and Router2 is setup as 192.168.0.33 but it is presented to PC2 as 192.168.1.1.... so i need to disable DHCP on Router2 and set its 'default gateway' as 192.168.0.1? I also need to make sure Router2 sets all IPs to be in the 192.168.0.[X] range? – zdanman Dec 26 '16 at 3:33
  • What do you mean Router2 is presented to PC2 as 192.168.1.1? You can only have one device dishing out IP addresses at a time, so yes turn off Router2's DHCP service. PC2 should obtain its IP address from Router1's DHCP service, and therefore automatically get that as its Default Gateway all in the 192.168.0.0 range. Router2 IP is set statically from its web browser portal, and basically just relays information packets from PC2 to Router1 as a switch. Everything being on the same IP /subnet mask range – Edward Dec 26 '16 at 4:06
  • updated the question above. please see. thanks. – zdanman Dec 26 '16 at 14:37
  • Pc2 will still retain the previously given IP address for a time or unless released. IPconfig /release. – Edward Dec 26 '16 at 14:57
0

As addition to the above answer.

Try to allow in your Windows firewall the respective connections e.g. Port 445/137-139.

Cause:

This behavior may occur if you enable a firewall on the network connection that you use for your home or office network. By default, a firewall closes the ports that are used for file and print sharing to prevent Internet computers from connecting to file and print shares on your computer. Resolution To resolve this behavior, use a firewall only for network connections that you use to connect directly to the Internet. For example, use a firewall on a single computer that is connected to the Internet directly through a cable modem, a DSL modem, or a dial-up modem. If you use the same network connection to connect to both the Internet and a home or office network, use a router or firewall that prevents Internet computers from connecting to the shared resources on the home or office computers.

Do not use a firewall on network connections that you use to connect to your home or office network unless the firewall can be configured to open ports only for your home or office network. If you connect to the Internet by using your home or office network, a firewall can be used only on the computer or the other device, such as a router, that provides the connection to the Internet. For example, if you connect to the Internet through a network that you manage, and that network uses connection sharing to provide Internet access to multiple computers, you can install or enable a firewall only on the shared Internet connection. If you connect to the Internet through a network that you do not manage, verify that your network administrator is using a firewall. From here

If the above doesn't works try to foward "locally" the ports 445/139 on your routers. For security reasons it is not advised to use it over Internet.

Open the router-managment page with a browser on 192.168.1.1 or something which is set.

Go to forward ports and set it to the right port/ip and save it.

A short description here

The following ports are associated with file sharing and server message block (SMB) communications:

  • Microsoft file sharing SMB: User Datagram Protocol (UDP) ports from >135 through 139 and Transmission Control Protocol (TCP) ports from 135 >through 139.
  • Direct-hosted SMB traffic without a network basic input/output system >(NetBIOS): port 445 (TCP and UPD).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.