128

Google Chrome, like almost every web browser in recent memory, used to have an option to change the character encoding for the webpage being viewed by going to MenuToolsEncoding (or some similar location). This is extraordinarily useful in case the website misrepresents its encoding in its headers, or, failing to do so, Chrome mistakenly detects the encoding of the page.

However, it seems as though in recent versions of Chrome, this option to manually override the character encoding is… missing. Either missing, or moved somewhere very obscure, because I cannot find it anywhere.

I'm currently looking at a mojibake-filled webpage in what I presume should be Russian, which is entirely unreadable and unusable because Chrome is mistakenly rendering it with the wrong character encoding.

How can I change the character encoding for a webpage in Google Chrome?

Edit: For reference, I'm on Version 55.0.2883.87 m, and the encoding option is flat-out missing from the Tools menu:

enter image description here

118

Unfortunately… a Christmas-box from Google Chrome: Chrome encoding options gone?:

Chrome 55 has removed the Encoding menu and Chrome will do auto-encoding detection now:

https://bugs.chromium.org/p/chromium/issues/detail?id=597488 - Remove encoding menu

Manual encoding selection is not necessary any more as the new encoding detector is turned on by default.

Manual encoding switching may be able to be done by use of Chrome extensions.

Marked as best answer by Kameron M - Community Manager

| improve this answer | |
  • 91
    sigh~ Thanks for the information; rather a pity the new encoding detector is hot garbage. – Meshaal Dec 27 '16 at 1:47
  • 13
    This is a really sad turn of events. It seems that Chrome cannot correctly detect Shift-JIS encoding properly in all cases, which is becoming a hassle for me while doing research on Japanese webpages that haven't been updated in many years... At least Firefox lets me manually select Shift-JIS. – recognizer Feb 9 '17 at 21:29
  • 7
    Unfortunately... many websites still mangle their own encodings. – Nick T Jun 13 '17 at 20:43
  • 6
    Chrome can't even detect codepage on the saved G+ page. This is retarded. Google's community managers are retarded too if they mark such answers as accepted and freeze threads so I can't even tell them there that they broke Chrome. – Nakilon Feb 13 '18 at 6:44
  • 6
    Just adding my comment here screaming that whoever decided to remove this probably don't read anything other then ASCII, coming here after opening a txt file that isn't detected correctly, not to mention all pages that needs different encodings. – NiKiZe Jun 10 '18 at 16:42
25

You can now use extensions. Here is an example https://chrome.google.com/webstore/detail/set-character-encoding/bpojelgakakmcfmjfilgdlmhefphglae

| improve this answer | |
  • I tried to add a user-defined encoding (ISO-8859-1) in the settings of that addon without any luck. The "save" button does nothing. – Anders Lindén Jun 16 '18 at 14:54
  • @AndersLindén Try to close the option page then recheck the result – user2686101 Jun 16 '18 at 15:22
  • I have tried this extension, but unfortunatelly, it require to refresh the page. And it is not able to resend the POST data :-( – Ondrej Nov 21 '18 at 17:14
  • The huge and bloated Chrome needs an extension to do something that all the other browsers have done for decades, since the inception of internet. – Ant_222 Apr 24 at 18:36
-6

There should be a button in the upper-right corner called "Menu" (three horizontal lines). Then try Menu → More tools → Encoding or Menu → Tools → Encoding(E)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.