2

I created a VM (host: Fedora 25, guest: LUbuntu 16.10) using virt-manager. When I start it and click on the window, I see two cursors: one host cursor and another guest cursor:

There are two mouse pointers

The movement of the guest cursor is restricted by the host cursor because it can't leave the screen boundaries. Also, sometimes the guest cursor doesn't appear and then I can't use mouse to interact with the guest (the keyboard still works). The offset of cursors isn't constant. I can move the guest cursor around the host cursor by moving the mouse fast in one direction and then slow in the opposite.

How can I make the host cursor disappear when I want to interact with the guest?

6

This is an issue with KVM, not just virt-manager.

It's possible to fix on the command-line for users not using virt-manager:

  1. Shut down your VM
  2. Enter the following on the host command-line:

    GUEST=your-vm-name
    virsh dumpxml "${GUEST}" > "/tmp/${GUEST}.xml"
    
  3. Open "/tmp/${GUEST}.xml" in any text editor (e.g. nano, vim).
  4. Within the <devices> tag, add this line (preferably near the other <input> tags):

    <input type='tablet' bus='usb'/>
    
  5. Enter the following on the command line to update the VM guest configuration:

    virsh define "/tmp/${GUEST}.xml"
    
  • 1
    If you're using virt-manager, you can go to the VM's settings and add a new Input device, choosing Tablet. It will achieve the same thing. – springloaded Dec 16 '17 at 21:42
8

As described here this can sometimes happen when creating a fully virtualized guest. The page I linked to also suggests a workaround: you can add a "Graphics Tablet" device to your VM.

To do this:

  1. Shut down the VM
  2. Click View -> Details in the menu
  3. Click the "Add Hardware" button (it's at bottom right corner of the dialogue)
  4. Select "Input" from the list on the right
  5. Select "EvTouch USB Graphics Tablet" from the drop-down
  6. Click "Finish":
  7. Click View -> Console to exit the settings view
  • Brilliant, thx! The mouse in my Android QEMU VM was going nuts in windowed mode when viewing via VNC... this fixed it. – Jay Marm Mar 29 '18 at 20:59
1

I had the same issue.

I managed to solve it by installing the spice Windows Guest Tools.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.