0

I have an ASUS UX50V laptop. Both Linux Mint 18 32-bit and Linux Mint 18.1 64-bit identify the video card as "NVIDIA Corporation: G98M [GeForce G 105M]". https://www.asus.com/Notebooks/UX50V/specifications/ concurs with the 105M designation.

I add "ppa:graphics-drivers/ppa" as a software source, per https://johners.tech/2016/07/installing-the-latest-nvidia-graphics-drivers-on-linux-mint-18/, and then I see two nvidia options available to me:

  • nvidia-304 (NVIDIA legacy binary driver - version 304.134)
  • nvidia-340 (NVIDIA binary driver - version 340.101)

Whenever I set it up to use either I get the following error message:

Cinnamon just crashed. You are currently running in Fallback Mode.

Do you want to restart Cinnamon?

Here's /var/log/Xorg.0.log for the 32-bit install with the 304.xx driver:

http://pastebin.com/fVfeKqfd

Here's /var/log/Xorg.0.log for the 64-bit install with the 340.xx driver:

http://pastebin.com/w8WS1Wnu

Both logs have the same two errors:

(EE) [drm] Failed to open DRM device for (null): -22
(EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)

I've tried both drivers and get the same result. Is the GeForce G 105M simply not supported? If so then why would Driver Manager list both as a suitable drivers?

1 Answer 1

1

I'd definitely start by looking at the Xorg logs. If Xorg crashes trying to load it should log the reasons why there. This is often due to incompatible versions of Xorg driver and vs kernel driver.

According to the info at http://www.nvidia.com/object/IO_32667.html, your video card requires the 340.xx driver; the older 304.xx does not show support for your card.

The error you're getting in the Xorg log is happening because it is loading the 304.134 kernel and X driver/modules -
[33.425] (II) NVIDIA GLX Module 304.134 Fri Dec 9 12:08:55 PST 2016
[33.617] (II) NVIDIA dlloader X Driver 304.134 Fri Dec 9 11:48:48 PST 2016
and then it unloads it -
[33.658] (II) UnloadModule: "nvidia"

I'd suggest two things.
First, make sure all versions of NVidia X and kernel drivers are uninstalled.
Then, install just the latest 340.xx driver.

I've had issues in the past where using a packaged driver (which it seems you are) and using the proprietary NVidia installer downloaded directly from their website, on the same machine but at different times, will end up with both installed and highly likely to be in conflict with one another.

Another possibility is the nouveau driver not being blacklisted. It generally should be, so the proprietary nvidia driver and the mainstream nouveau driver aren't both vying for control over your display adapter.
On my system, I have
$cat /etc/modprobe.d/nvidia-installer-disable-nouveau.conf
# generated by nvidia-installer
blacklist i915
blacklist nouveau
options nouveau modeset=0

You may have a file with similar contents with a different name. If you have no reference to blacklisting nouveau in your modprobe configs at all, you may want to try creating a file with those contents and depositing it in your /etc/modprobe.d directory, or the moral equivalent thereof on Mint.

6
  • Here it is with 340.xx: pastebin.com/w8WS1Wnu I get the same thing :( It's on a brand new Linux Mint install too so the 304.xx driver was never installed.
    – neubert
    Dec 28, 2016 at 5:15
  • It looks like blacklist nouveau is present in /etc/nvidia-340_hybrid.conf. blacklist i915 and options nouveau modeset=0 are not present in any *.conf file. I'll try adding them to the afore mentioned nvidia conf file and see what happens. Thanks!
    – neubert
    Dec 28, 2016 at 6:11
  • Didn't help. Another observations, if it helps. alias nouveau off is present in nvidia-graphics-drivers.conf.
    – neubert
    Dec 28, 2016 at 6:19
  • It's in /etc/modeprobe.d/. My last comment was a typo. Thanks!
    – neubert
    Dec 28, 2016 at 6:35
  • what do you get from: modprobe nvidia ; lsmod | grep nvidia
    – Rubio
    Dec 28, 2016 at 6:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.