Just bought a new PC and I'm trying to install win 7 from USB. I had my ISO file on my other laptop, and I used windows usb tool to copy the ISO to the USB after formatting it to exFAT (tried NTFS but it didn't copy... <- why is that? ).

Anyway, the UEFI BIOS menu recognizes my USB (4 GB) and starts loading the windows boot manager, but then I get this msg:

"No device drivers were found. Make sure that the installation media contains the correct drivers, and then click ok"

Now, I've seen some solutions to this problem like swap USB ports (I did - didn't help. I have 2 blue USB ports (USB 3) and a whole bunch of regular (USB 2), neither works). Also I saw an advice to turn off something in BIOS so the boot will be able to work with USB3, but as I see it, the BIOS already recognized my USB, so, why wouldn't continue with installation?

The USB is still recognized while in boot manager, I think. After I get this msg, I can browse for the drivers, and inside my PC, there is a dir of boot X - my USB...

Can you help pls? Thanks!

To make things clearer:

I see a screen like this one, but with no items on the list...



1 Answer 1


I faced a similar problem before, while I was trying to install Windows 10.

I solved the problem by experimenting though!

I used Rufus to create my USB image. I made some changes with the partitioning scheme of the USB and it finally worked. I forgot what I chose but as far as I know it changes with system to system. I think it might be the problem for you too.

Hope it helps!!

  • OK thx! I'm currently trying to add USB3 drivers to the USB as mentioned here [codeabitwiser.com/2014/03/… in hope it'll work Commented Dec 28, 2016 at 9:02
  • Ok, all the best buddy! but all I get from that link is a 404 - not found page!
    – Ragav Ssr
    Commented Dec 28, 2016 at 15:19
  • that's because the url takes my "]" with the address... remove it and you'll get to the website Commented Dec 28, 2016 at 18:19
  • ohhh! got it! didn't notice that!
    – Ragav Ssr
    Commented Dec 29, 2016 at 17:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .