6

After clearing all cookies and cache on my Google Chrome, Google Chrome's auto-completion in the omnibox is no longer working 100% fine. It gives recent related searches and related history items in the auto-completion bar, but that's it.

In Google's Help Center, it says that Search Predictions come from:

  • The terms you’re typing.
  • Relevant searches you’ve done in the past (if you’re signed in to your Google Account and have Web & App Activity turned on).
  • What other people are searching for, including Trending stories Trending. Trending stories are popular topics in your area that change throughout the day. Trending stories aren’t related to your search history.

Only the second one applies to me. The rest don't appear (but they used to appear before I cleared the cache). Searching on the web, I found out that I have to enable use a prediction service to help complete searches and urls typed in the address bar in my Settings. I have it enabled, but still nothing changes.

Here is good example of this not working: when I used to type in a calculation in the address bar, say 2+2, it gives the result right away as one of the results without me having to hit enter and search it. But now I have to search for it to get the result.

Here is an image to show what I mean by it not working

2+2

As you can see, it does not give the result of the expression (ie 4). It only gives one of my bookmarks as the result (or for other searches it returns recent searches and related items in my history).

Details:

  • Device: Mac with OS El Capitan

I am looking for a fix for making my Google Chrome's address bar's autocompletion work completely again. Any help is appreciated.

4

Is there a fix to make Google Chrome's address bar's autocomplete work properly?

First check the following:

  • Go to "Settings" > "Manage search engines" -> "Default search settings"

  • Copy the value for and make sure it is set to:

    {google:baseURL}search?q=%s&{google:RLZ}{google:originalQueryForSuggestion}{google:assistedQueryStats}{google:searchFieldtrialParameter}{google:iOSSearchLanguage}{google:searchClient}{google:sourceId}{google:instantExtendedEnabledParameter}{google:contextualSearchVersion}ie={inputEncoding}
    
  • If this value is not correct then you need to Reset your Chrome settings to resolve this. See the instructions below.


Reset Chrome settings to default

You can restore your browser settings in Chrome at any time. You might need to do this if apps or extensions you installed changed your settings without your knowledge. Your saved bookmarks and passwords won't be cleared or changed.

  1. On your computer, open Chrome.
  2. At the top right, click More More and then Settings.
  3. At the bottom, click Show advanced settings.
  4. Under the section "Reset settings,” click Reset settings.
  5. In the box that appears, click Reset. ​

These steps won't provide a full reset. For example, some settings like fonts or accessibility won't be deleted. To create a new user profile, add a new user in Chrome.

What changes when you restore your settings

The following settings will change back to the default:

  • Default search engine, which is changed back to Google. Learn how to set your default search engine.
  • Homepage and tabs. Learn how to set your Chrome homepage and set default startup tabs.
  • The new tab page. Learn how to set the page that a new tab opens to.
  • Tabs you have pinned. Learn how to pin tabs.
  • Content settings, like letting a site show you pop-ups or use your microphone. Learn how to change your content settings.
  • Cookies and site data, like items in an online shopping cart. Learn more about cookies and site data.
  • Extensions and themes. Learn more about extensions and themes.

Only the settings for the Chrome profile you're signed in to will be reset. Your new settings will apply across all computers or devices where you’re signed in to your active profile.

Source Reset Chrome settings to default

  • Changing the search engine to the original Google made it work (since I had changed it to a custom Google url for some weird reasons). Thanks :) – Cows quack Jan 3 '17 at 18:26
  • Is there a way to make custom Google url work then? There is this particular server (172.217.9.228) that gives me superb response time -- seemingly due to opportune routing. I use the same query and replaced {google:baseURL} with https://172.217.9.228/ but it doesn't work. – Argyll May 24 '18 at 14:39
  • @argyll no idea, sorry – DavidPostill May 24 '18 at 16:19
2

Go to chrome://settings/?search=search.

Under Privacy and security select the checkbox next to Use a prediction service to help complete searches and URLs typed in the address bar.

  • I don't see such a checkbox – Michael Sep 4 at 22:50
0

I had the same problem few days ago. It seems whenever I am logged in to my Google account, the Google autocomplete feature stops working. I have two Google accounts, so I figured let me log in to one account at a time to see which one causes the issue. I logged in to my first account and the problem remained. However, when I logged off from that account and logged in to the other one, the autocomplete feature worked normally.

If you have more than one Google account try signing in using one of the accounts instead of the other. For example, if you are used to signing in to Account A first then Account B, try this time to sign in to Account B first then Account A and see if it works.

In my case I used to sign in to my first account then the second account, but when I signed in to the second account then the first account, the autocomplete was back to normal.

Good luck

0

In my case, the issue was simply that the Search engine used in the address bar setting was set to "google.se" instead of simply "Google".

You will find this setting under chrome://settings/ --> Search Engine --> Search engine used in the address bar

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.