-1

Update: my question has shifted a bit but I think it is still valid. It's just not limited to my drive, but my PC as a whole.

It seems my drive get bad sectors as Yorik pointed out, when I run them through any formatting software, but CHKDSK won't fix them.

With a healthy drive you can choose to format it to whatever filesystem you want. Not in my case.

Preferably I'd like my partitions in NTFS file system, going with my Windows (I use Win10 Home x64 on a separate drive and volume with NTFS). FAT32 is not a valid option as it corrupts my data.

I've gone through hours of pain waiting doing low level formatting with GParted. I've gone through with MS DiskPart ( commandwindows.com/diskpart.htm ) only to realise the drive and Volume simply won't format to NTFS file system (usually previewed as RAW in Disk Manager). I've started doing UBCD as suggested, I can't give up more days to this now. I need my PC for other stuff too...

To summarize:

  • I can blank my drives using any given method.
  • Everything seems fine until I run any formatting method and corrupts the given drive.
  • Simply formatting with MS DiskPart, Disk Manager or EaseUS from whatever format to NTFS result in partition going RAW.
  • Formatting to FAT32 result in corrupting files placed on the drive.

EDIT: I've tried to convert the Disk with "convert E: /fs:ntfs". As Keltari said.
It gives the following output. (Would use pastebin here, not enough rep D: )

C:\WINDOWS\system32>convert E: /fs:ntfs
The type of the file system is FAT32.
Enter current volume label for drive E: SAMSUNG HDD
Volume SAMSUNG HDD created 26/12/2016 23:56
Volume Serial Number is 1F13-3B1F
Windows is verifying files and folders...
File and folder verification is complete.
Windows found errors on the disk, but will not fix them
because disk checking was run without the /F (fix) parameter.

Lost chain cross-linked at cluster 178250. Orphan truncated. Lost chain
cross-linked at cluster 178762. Orphan truncated. Lost chain
* cut *
cross-linked at cluster 185930. Orphan truncated.
Convert lost chains to files (Y/N)? Y
1024 KB in 16 recoverable files.

Windows has checked the file system and found problems.
Run CHKDSK with the /F (fix) option to correct these.

   244,168,704 KB total disk space.  
           320 KB in 5 hidden files.  
            64 KB in 1 folders.  
        22,464 KB in 351 files.   
   244,144,704 KB are available.


   65,536 bytes in each allocation unit.   
3,815,136 total allocation units on disk.  
3,814,761 allocation units available on disk.  

The volume may have inconsistencies. Run Chkdsk, the disk checking utility.
The conversion failed.
E: was not converted to NTFS The conversion failed.

I should also say that I've done this and CHKDSK :E /F (Sometimes with /F /V /R /X) on repeat.

And here is the latest CHKDSK log.

A few days later... (Happy New Year 2017) I've tried another typical HDD 1TB drive because I had no patience left. To my surprise the same thing happen to that drive!!

I'm naturally starting too look for other factors like my motherboard or possibly my SSHD (SSD and HDD in one) that I run my Windows off.

List of my specs without any broken drives and Optical drive only for UBCD:

Operating System
    Windows 10 Home 64-bit
CPU
    Intel Core i5 2500K @ 3.30GHz   38 °C
    Sandy Bridge 32nm Technology
RAM
    8.00GB Dual-Channel DDR3 @ 686MHz (8-8-8-22)
Motherboard
    ASUSTeK Computer INC. P8H61-M EVO (LGA1155) 28 °C
Graphics
    BenQ GL2450H (1920x1080@60Hz)
    227ELH (1920x1080@60Hz)
    4095MB NVIDIA GeForce GTX 970 (Gigabyte)    29 °C
Storage
    223GB KINGSTON SV300S37A240G (SSD)  24 °C
    931GB Seagate ST1000DX001-1NS162 (SATA) 34 °C
Optical Drives
    Optiarc DVD RW AD-5280S
Audio
    Realtek High Definition Audio
  • have you tried clearing the disk using diskpart ( commandwindows.com/diskpart.htm ) – Yorik Dec 27 '16 at 22:30
  • "I've put equal amount of time in MS DiskPart only to realise the drive simply won't format" I'll try make it more clear. – OskyEdz Snakehult Dec 27 '16 at 22:32
  • Format is not complete partition removal, nor is zeroing (which is what clean does), so I yes I found that unclear. Also, cross-linked files are a sign of bad sectors, so there is evidence of hardware failure; does it "click and skip" when you run scans on it? – Yorik Dec 27 '16 at 22:39
  • I did remove partitions with Diskpart or at least to the point where it shows in Disk Management as Unallocated. Okay I don't remember how I did it in Diskpart, but I for sure deleted all of it's partitions with EaseUS I don't really get the "click and skip". I run "chkdsk E: /F" I answer "Y" for "Convert lost chains to files". In this moment I'm running the command on 65%, I'm updating with full log once it is complete. – OskyEdz Snakehult Dec 27 '16 at 22:53
  • FAT32 does not corrupt data. There’s obviously something else going on. – Daniel B Jan 1 '17 at 19:54
1

If this issue really taking up as much time as it sounds like, I would (as one last effort) try to bypass all possible OS hindrances and perform the below steps. It's a lot overkill and it will take a while to run, but requires very little hands-on and eliminates all OS/driver complications and gets right down to diagnosing the hardware (the drive).

I recommend using the UBCD utility for all below steps, as it includes all tools that you need.

http://www.ultimatebootcd.com/

securely wipe the drive

I recommend DBAN.

Use whatever wiping method you feel is necessary. If you have the time to spare do the DOD method (9 passes). Note that you will never be able to recover the data from the drive once you start this.

Check the drive for errors again

I recommend HDAT2.

It is true that this step is the same as checking the SMART status results but there are some differences:

  1. But we don't know exactly how SMART status is scanning. If it's linear or non-linear. And where on the drive are the errors detected? This will tell you that. As long as it isn't in the beginning sectors then you're fine.
  2. It doesn't hurt to double check from different environments to see if we get different results.
  3. Bypassing OS/driver layers and go straight to disk. Removing possible complications.

Format drive to NTFS

I recommend Parted Magic. https://partedmagic.com/

Use this tool to format the drive to NTFS. If it is successful and you can read/write files then you know the drive is working properly. If not then you know that the drive is the problem.

Following that, if you plug the drive into Windows and the partition is not found, then you know that Windows is the problem. Else all is good.

This is just what I would do as it's the easiest and quickest way to test just the hardware, ensure good results, and not spend large amounts of time on it. Hope this helps.

  • Actually, this sounds like a good idea. the DOD wipe is a waste of time though, just zero out the drive. – Journeyman Geek Dec 28 '16 at 0:01
  • I've managed to get the Live version running, but I have no clue nor a manual for this. I don't see any DBAN, DOD, HDAT2 or Parted Magic. I've got GParted, Truecrypt and Testdisk and some other geeky stuff I haven't seen. – OskyEdz Snakehult Dec 28 '16 at 1:15
  • The three tools that I recommended in order are: – Michael Timmerman Dec 28 '16 at 6:47
  • The three tools that I recommended in order are: /HDD/Disk Wiping/Darik's Boot and Nuke /HDD/Diagnosis/HDAT2 /Others/Parted Magic – Michael Timmerman Dec 28 '16 at 6:49
  • A list can be found on the UBCD homepage if you want to read more about the tools ultimatebootcd.com – Michael Timmerman Dec 28 '16 at 6:51
0

You say the drive is currently FAT32? Try converting it to NTFS. From an administrative command prompt type:

convert d: /fs:ntfs

Where d: is the drive that you want to convert

  • Strange, when I do it tells me to run CHKDSK with /F. I do, get successful and then run your command again. Every time I tells me to run CHKDSK, even when I've done so. – OskyEdz Snakehult Dec 27 '16 at 11:39
0

Ok, you probably have a bad sector in the wrong place, somewhere critical where NTFS wants to write structure data.

Try this. Shrink the partition, by say 100mb on each side. Then try formatting NTFS quick format.

If that fails try increase to say 1gb of free space on each side.

Now, if you wanted to spend the time you could do this a bunch of times to determine where the error is.

If that fails try the reverse logic.

Create 1gb partition, and if errors occur leave a gap at the front until errors don't occur. Once you find a good starting point, double the partition size until you have errors. 2,4,8,16,32,64,128gb.
If you encounter failure, try half sizes.

For example we know 250 would fail, how about 128+64 or 192gb partition.

Run chkdsk /f afterwards.

Actually chkdsk /R would be better, but eventually become to time consuming.

  • Hmm...it seems really tedious to manually check for the bad sector. I'll try Michael Timmerman suggestion first, but I'm not turning you down! – OskyEdz Snakehult Dec 28 '16 at 0:46
  • @OskyEdzSnakehult I personally would skip the manual bad sectors thing, until you reached the max size a quick format works at. – cybernard Dec 28 '16 at 0:50
  • Oh! I think I get it now. There is a limit to how many sectors I can check in one go. – OskyEdz Snakehult Dec 28 '16 at 0:54
  • You can chkdsk as many sectors as you want, it just takes longer for the check to complete. We are trying to get a working drive, not waste hours waiting for chkdsk(s) to complete. – cybernard Dec 28 '16 at 1:09
0

I guess can answer my own question now that the problem is solved on my end.

Thanks everyone for helping me out, although none of your answers was what in the end helped me. You did find most of the possible causes, very helpful if anyone else find himself in this situation.

My solution was:

  1. Shut down PC, unnecessary but I drain the mother so no lights was on.
  2. Disconnect all SATA cables
  3. Started BIOS and loaded Default settings. (You should prob. remember your current settings if something else stops working...)
  4. I then had to make sure my SATA configuration was set to ACHI mode, instead of IDE.
  5. Then it is a matter of luck. I have 5 SATA cables, 4 SATA contacts and 3 disk drives. So mix and match until you get it right.
  6. And finally while booting just let it do it's thing. Mine told me it was repairing and diagnosing the drive canceling often result in BSoD.

OskyEdz - disconnected from superuser.com

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.