0

I'm running a Windows 2012 R2 server that I need to install Visual Studio 2015 on. The issue I have is that KB2919355 is a prerequisite but when I try and download it from the Microsoft download page I can only select the version for Windows 8.1 from the download list. If I try and install the Windows 8.1 version of the file I get the error message "The update is not applicaple to your computer" which makes good sense.

I have tried looking for it on google but all links seem to point to this download page. I also tried installing it via Windows Update but the process seem to be stuck at "Checking for updates...". Does anyone know how to aquire this hotfix for Windows Server 2012?

UPDATE: Windows Update finally completed the scan, but KB2919355 is not part of the list. In fact it is explicitly stated that security update KB2962123 does NOT contain KB2919355.

3

Just wanted to follow up on this because this problem and exact solution solved my issue. My issue was trying to install PhP 7.1.1 (x64) on a brand new Server 2012 r2 (OEM) system. Since this was a rabbit hole problem, I wanted to elaborate on it so the next person can find it easier.

  1. Install PhP 7.1.1 (x64)
  2. Error on dependency install MS Visual C++ 2015 Redistribute
  3. Error in log: Update Error 0x80240017
  4. Research said Windows Update was missing KB2919355 despite saying no updates waiting
  5. TechNet indicates KB2919355 is a roll-up update. Installed the pre-requisite updates to install KB2919355. Now Update history shows KB2962123 without KB2919355.
  6. Try and install KB2919355 and I get "The update is not applicaple to your computer" Google that and it lead me to here.
  7. To install KB2919355 on Server 2012 r2 you need to install KB2939087 and KB2975061 Installed those two KB's, then you can install KB2919355
  8. Install KB2939087 and KB2975061 then reboot. Install KB2919355, then reboot. Then you can install microsoft visual c++ 2015 redistributable package (x64). After that has sucessfully installed, you then can run Web Platform Installer 5.0 and install PhP 7.1.1 (x64). Visual C++ 2015 will no longer be a dependency install and you are good to go.

I would suggest installing the additional windows update roll-ups, since after all that effort you are only patched to about April of 2014.

TechNet's roll-up page: Technet's Website

  • Tks so much for step 7! It was killing me – Pascal Apr 18 '17 at 20:57
0

Thanks to @Artiom on stackoverflow I was able to solve the error.

I had to install KB2939087 and KB2975061 before installing KB2919355 but it worked. I will donate this thread to the community so give @Artiom any probs you may wish to give.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.