1

I recently bought a 8GB promaster compact flash card (model number CF08AQA6Z-XX000-P) for use in my Canon EOS 20D camera. I purchased the Insignia NS-CR25A2 card reader from Best Buy, and tried to pull my photos off in Windows. Nothing happened, so I tried to open the file explorer, which proceeded to hang for around 5 minutes. At that point I suspected something was wrong, so I just pulled the card reader out. I decided to boot an Ubuntu live CD (which I'm typing from right now) and see if I could make it work in linux. The device would not mount (even if I tried to do so manually), but it is listed as a block device (/dev/sdc). This concerned me, so I tried to make a backup of the card via dd if=/dev/sdc of=[MyHardDrive]/CFCARD.img bs=1M, which failed! I got an error like "no media found". At this point, I was pretty worried that something had gone horribly wrong, so I did the following:

  1. Bought a new card (same model) and a new card reader (different model, from Radioshack).
  2. Took some pictures on the new card.
  3. Inserted the new card into the new card reader in Windows. It worked perfectly! I pulled all the photos off no problem.
  4. Ejected the card and inserted it into the old card reader. I had the same experience as before where explorer hung for minutes.
  5. Booted up the old card in the new card reader in Ubuntu. This time I was able to make a copy of the card with dd.

The above experience led me to believe that the first card reader had corrupted my cards, and so I'm only been using the newer card reader now. But I don't know how to fix my cards! Not only have I been unable to recover the photos from the first card, I can't even get the new card working! (I already have the new card's photos so I have no concerns about wiping it). Here's what I've tried with the new card:

  1. Using gparted to make a new partition table (msdos). It says its working, but when it refreshes the device list nothing has changed. It also said unrecognized disc label. I wanted to correct this manually, which led me to step 2.
  2. Using parted to make a new partition table and partition (unit GB then mklabel msdos then mkpart primary ext2 0 5). It doesn't give me any errors but nothing has changed after I quit.
  3. Wiping the first 1M of the device (dd if=/dev/zero of=/dev/sdc bs=1M count=1) and repeating steps 1 and 2.
  4. Wiping the entire device (dd if=/dev/zero of=/dev/sdc bs=1b count=14745024) and repeating steps 1 and 2.

I am scared to mess too much with the old card because I'd like to recover the photos if possible, although I do have an image of it on my disk which I can mess with once I burn it to a USB stick. I've uploaded that image to my box account and you can download it here.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.