1

CONTEXT

Acer Aspire D255E configured with Win7. WiFi trumps Ethernet connection when both are engaged. In order to use the wired LAN connection, the WiFi must be disabled. When this laptop is running Ubuntu, LAN trumps WiFi as expected: therefore not a hardware issue.

GOAL

When Ethernet is connected, WiFi takes a back seat: likewise when Ethernet is disconnected, WiFi is engaged

QUESTION

How is WiFi configured to be secondary to Ethernet?

  • 2
    You can do it by manually assigning metrics. See this question and my answer. – VL-80 Dec 30 '16 at 14:50
  • @VL-80: Intruiging! This seems to configure prioritization. When the machine is faced with sending out traffic, will the metric prioritization be followed? – gatorback Dec 30 '16 at 14:56
  • It should. From Wikipedia: Metrics are used to determine whether one route should be chosen over another. – VL-80 Dec 30 '16 at 14:59
  • @DavidPostill: are edits done manually or are they done by some clever automation? – gatorback Dec 31 '16 at 15:58
  • @gatorback Semi-manually. I have a spell checker ... – DavidPostill Dec 31 '16 at 16:00
0
  • Go the Start Menu and type Network Connections and hit Enter
  • In the Network Connections window press the Alt key to make the menu bar appear at the top
  • Choose Advanced and go to Advanced Settings
  • In the Advanced Settings window you'll see a list of Connections along with arrow keys to the right that allows you to modify the preference order of your available connections. Move your wireless adapter to the top of the list.

enter image description here

  • Attempts with LAN and wifi at the top of the list were unsuccessful: rebooted each time to test. Suggestions please? Very well written and double bonus points for screenshot – gatorback Dec 30 '16 at 2:40
  • This is/should be the default behavior though – Journeyman Geek Dec 30 '16 at 2:49
  • @JourneymanGeek: Agreed. In my experience a live LAN connect event disengages active wifi. The system is dual boot and exhibits this expected behavior with Ubuntu – gatorback Dec 30 '16 at 14:42
  • @JourneymanGeek Thought this was interesting: superuser.com/questions/722963/… – gatorback Dec 30 '16 at 22:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.