8

My computer frequently fails to sleep.

How To Reproduce The Problem

  1. Open Google Chrome.
  2. Play a video on YouTube.*
  3. Open a new Chrome tab to some other website (such as SuperUser).
  4. Close the YouTube tab (but keep the other tab open such that Google Chrome isn't completely closed).
  5. Let computer sit for however many minutes are required for sleep. (But then it never sleeps!)

*(I'm 100% not sure that it needs to be YouTube, but I think the most likely scenario when I'm playing audio via Chrome is if I'm watching a YouTube video.)

I'm using Windows 10 Pro with Google Chrome Version 55.0.2883.87 m (64-bit). ("Google Chrome is up to date.")

How To Diagnose

I opened Command Prompt as an administrator and ran powercfg /requests and get this result:

[DRIVER] High Definition Audio Device (HDAUDIO\FUNC_01&VEN_10EC&DEV_0892&SUBSYS_1849D892&REV_1003\4&13fd1513&0&0001) An audio stream is currently in use.

Through trial and error, I've narrowed down the offending program to Google Chrome. After quitting Chrome completely (all tabs) and running powercfg /requests again, the result is:

DISPLAY:
None.

SYSTEM:
None.

AWAYMODE:
None.

EXECUTION:
None.

PERFBOOST:
None.

ACTIVELOCKSCREEN:
None.

And then the PC sleeps appropriately.

What's weird is that Chrome is not actively playing an audio stream. But it has played audio recently, even though that tab is now closed and gone.

How can I ensure that my Windows 10 Pro can sleep normally even when Chrome is still open and even when a recently-closed Chrome tab played some audio?

UPDATE:

This is driving me crazy!

I've even disabled all Chrome extensions. My enabled extensions had been:

  • Google Docs
  • Google Docs Offline
  • Google Sheets
  • Google Slides
  • LastPass: Free Password Manager

But I'm still having the problem. I'm not 100% sure that YouTube is relevant to the problem, but I don't know when else my Chrome uses audio.

By the way, it seems like many other people have experienced Chrome keeping their computer awake:

I'm shocked this hasn't gotten more attention because it's really annoying.

  • The video is what is keeping your PC awake. Have you looked at sleep timers for Windows? These tend to override the video and suspend the PC as if you had done it manually. See superuser.com/questions/42124/… – Burgi Jan 11 '17 at 0:41
  • @Burgi Why/how would a closed Chrome tab (that had been playing a video) keep the computer awake? Thanks for the link to sleep commands, but I'd rather solve the problem at the root cause instead of layer bandaids on top of it. – Ryan Jan 11 '17 at 2:14
  • I'm starting to think it's a Chrome bug because even powercfg -requestsoverride didn't work, and then I found Comment 79: bugs.chromium.org/p/chromium/issues/detail?id=179007#c79 – Ryan Jan 17 '17 at 13:18
  • 1
    I'm also shocked people are not annoyed by this!!! My wife's computer NEVER goes to sleep because she loves leaving like 50 tabs open and one of them is prone to have some sort of video on it (usually an AD). I'll look into the sleep timer but I agree that that is a band aid and Chrome is the one at fault. – Pedro Apr 25 '17 at 3:01
  • bug should be opened in chromium against this. – Atiq Rahman May 5 '18 at 7:36
5

This also drove me crazy. After trying many things, this one worked:

In short, (A)create a scheduled task to kill chrome if you computer has been idle for [IdleTime]. [IdleTime] has to be the same as your (B) "PC goes to sleep after" time you enter in Settings.

A: Create a scheduled task to kill chrome.exe

  1. Open Task Scheduler (hit windows key and enter "Task Scheduler")
  2. Click "Create Task ..." on the right side menu.
  3. On the General tab: enter "Close Chrome after [IdleTime] of inactivity". Do not enter the double quotes I typed on this step or any subsequent step.
  4. On the Triggers tab: hit "New...", then select Begin the task: "On Idle", hit OK
  5. On the Actions tab: hit "New...", then enter Program/script "taskkill", Add arguments "/F /IM chrome.exe /T"
  6. On the Conditions tab: Check "start the task only if the computer is idle for" and [enter your preferred IdleTime]
  7. Remember that even when you kill Chrome, your tabs are remembered. You just need to say "Restore" on the "Chrome didn't shut down correctly" prompt next time you open Chrome.

B: Set the official "PC goes to sleep after" setting

  1. Open "Power & Sleep Settings" (hit windows key and enter "Power settings")
  2. Set When plugged in, PC goes to sleep after [enter the SAME IdleTime you used on step A]
1

This solved the problem for me:

hunterdg said:
see http://www.google.com/support/forum/p/Chrome/thread?tid=3b1d41b0663a4d40&hl=en

in a command window:
powercfg -requestsoverride PROCESS chrome.exe awaymode display system

to remove the override:
powercfg -requestsoverride PROCESS chrome.exe

source: http://download.microsoft.com/download/7/E/7/7E7662CF-CBEA-470B-A97E-CE7CE0D98DC2/AvailabilityRequests.docx.

https://productforums.google.com/d/msg/chrome/vE7o1k0txtU/0ES4nTp01JsJ

1

After trying all of the above solutions, the thing that worked best for me is a Chrome extension called Mutetab. It will by default mute all background tabs, and the open tab if you open a different program on your computer. Of course, it also has an exclusion list for favorite sites, and you can always manually unmute when you want to listen to something. This disables the audio driver request, and lets the computer sleep. Hope that's helpful to someone. Facebook was especially egregious. Even with an autoplay blocker, it opens an audio channel for beeps and junk like that. So if you have facebook open, it's as if the computer is playing constant audio even if you can't hear anything.

0

I've had the same problem and am still looking for a "perfect" solution. For a long time I kept Chrome in the requestsoverride list, which in my case successfully prevented Chrome from blocking idle timeout.

The downside is that my displays would time out and shut off after the configured idle time--even when I'm watching Netflix or Youtube--because the Chrome process had lost the ability to send "still active" requests to the power subsystem. Sometimes I would work around this by opening a video in VLC and leaving it paused and minimised.

For now I'll await a solution that lets Chrome operate normally and doesn't require me to forcibly kill it, remember to shut it down manually every time I leave the PC, etc.

  • You can try POWERCFG /REQUESTSOVERRIDE PROCESS "\Device\HarddiskVolume4\Program Files (x86)\Google\Chrome\Application\chrome.exe" SYSTEM AWAYMODE EXECUTION. At least the display should be put in sleep mode correctly. For the box you need to edit the power saving settings to match the video length. – Gigamegs Apr 9 at 11:50
0

I found that a change to how Outlook.com does polling was enough to trigger a long-standing bug in Chrome that prevents sleep.

https://bugs.chromium.org/p/chromium/issues/detail?id=571250#c36

Polling by the Outlook.com beta calendar page (as of 2018-07-05) prevents timeout-based sleep in Windows 10 Version 10.0.17134.137 when using Chrome Version 67.0.3396.99 (Official Build) (64-bit). Turning off the "Outlook beta" slider allows my PC to sleep after its idle timeout as normal. Turning on the "Outlook beta" slider prevents my PC from entering sleep after its idle timeout.

None of the following solved the problem for me:

  • Disabling group policy "Allow applications to prevent automatic sleep"
  • Turning off the advanced Chrome setting "Continue running background apps when Google Chrome is closed"
  • Turning off the advanced Chrome setting "Use hardware acceleration when available"
  • Running the following commands at an elevated prompt:

    POWERCFG /REQUESTSOVERRIDE DRIVER "IDT High Definition Audio CODEC (HDAUDIO\FUNC_01&VEN_111D&DEV_76C7&SUBSYS_103C3AB5&REV_1001\4&3171535e&0&0001)" DISPLAY SYSTEM AWAYMODE

    POWERCFG /REQUESTSOVERRIDE DRIVER "IDT High Definition Audio CODEC" DISPLAY SYSTEM AWAYMODE

    POWERCFG /REQUESTSOVERRIDE DRIVER "USB Audio Device (USB\VID_08BB&PID_2902&MI_00\7&3a78c808&0&0000)" DISPLAY SYSTEM AWAYMODE

    POWERCFG /REQUESTSOVERRIDE DRIVER "USB Audio Device" DISPLAY SYSTEM AWAYMODE

    POWERCFG /REQUESTSOVERRIDE DRIVER "USB\VID_08BB&PID_2902&MI_00\7&3a78c808&0&0000" DISPLAY SYSTEM AWAYMODE

    POWERCFG /REQUESTSOVERRIDE PROCESS "\Device\HarddiskVolume4\Program Files (x86)\Google\Chrome\Application\chrome.exe" DISPLAY SYSTEM AWAYMODE EXECUTION

    POWERCFG /REQUESTSOVERRIDE PROCESS "chrome.exe" DISPLAY SYSTEM AWAYMODE EXECUTION

  • You can try POWERCFG /REQUESTSOVERRIDE PROCESS "\Device\HarddiskVolume4\Program Files (x86)\Google\Chrome\Application\chrome.exe" SYSTEM AWAYMODE EXECUTION. At least the display should be put in sleep mode correctly. For the box you need to edit the power saving settings to match the video length. – Gigamegs Apr 9 at 15:31

protected by Community Aug 5 '18 at 14:13

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.