1

My graphics card seemingly stops outputting a signal and I'm forced to restart the computer (replugging the HDMI cable does nothing). I'll be watching Netflix (can't overheat off Netflix!) or playing a game and then my monitor randomly loses signal and goes to sleep. I can still talk to my friends on Discord (voice chat), so the computer is still functioning. I take a screenshot every time it does this and I haven't seen any error messages except once when I was running 'Windows Experience Index' and it said: "The NVIDIA GeForce GTX 670 device is not removable and cannot be ejected or unplugged".

I should mention at my old house it worked flawlessly. So I figured it was a electrical grid issue and I bought an Uninteruptible Power Supply, which all my components and LAN cable connect to. Did not fix the issue.

In Windows Event Viewer it was saying "the Display driver "nvlddmkm" stopped responding and has successfully recovered." so I set the TDR-Delay to 8 seconds (from 2) and underclocked my memory and core by -100. Now I don't see that error in Event Viewer but the issue still occurs. Considering disabling TDR entirely?

Here's the what I'm getting in Event Viewer now after the monitor stops receiving a signal (Administrative Events):

Event Viewer Warnings

Something is causing the GPU to stop working and then it's unable to recover, as I understand? Any ideas about how to fix this or at least get the GPU to successfully recover in a couple seconds (much better than hard reset of computer).

I've checked wiring, temperatures (GPU max 85C in hardcore game), ran memtest, GPU/CPU benchmarks for 15+ minutes and like 500 other things. Don't know what to do!

Here's my PC specs:

Operating System: Windows-7, 64bit (Desktop)

System Model: Alienware X51 R2

BIOS: 07/13/15 11:13:58; Ver: 04.06.05

Processor: Intel(R) Core(TM) i7-4770 CPU @ 3.40GHz (8 CPUs), ~3.4GHz

RAM: 16GB

GPU: NVIDIA GeForce GTX 670

1

If you're able to take and store screenshots after the monitor goes to sleep, then the GPU isn't crashing. Windows 7 can't render frames without the GPU working.

It looks like you used to have a problem with heat or partial failure of the GPU causing reliability issues, thus the TDRs. But since you're no longer getting TDRs after underclocking and increasing the TDR timeout, that tells me that your GPU is now working well enough to be stable.

If you disable the TDR timeout, your PC would totally lock up (no ability to take screenshots or hear audio, etc) every time the GPU crashed, and it would stay locked up indefinitely or BSOD and you'd have to reboot. Similarly, if you're not getting BSODs when you do get TDRs, then your GPU is recovering from the crash successfully.

So this seems to be strictly limited to the display output path and has nothing to do with the "processing" part of the GPU. It could be:

  • The cable itself (or the connection to the port header on either side) might be failing.
  • Could be a problem with your monitor.
  • The display chip on the graphics card (there's a separate IC for, e.g. HDMI or DisplayPort codec) might be failing.
  • The header itself (the "port" interfacing between the innards of the graphics card and the cable) might be failing.

Things you should try:

  • With the same monitor, try running off of your Intel 4770 CPU's integrated graphics, by plugging your monitor into the motherboard (only - do not plug anything into the Nvidia card).
  • Try a different monitor if you have one.
  • Try a different Nvidia card if you have one.
  • Make sure you're running the latest Nvidia Game Ready drivers, in case it's a software or firmware issue.
  • Put your (same) Nvidia card into a different PCI Express slot (but plug the monitor cable into the Nvidia card, not the motherboard).
  • If your Device Manager shows an Intel HD graphics device even while you have your monitor cable plugged only into the Nvidia card, update your Intel graphics drivers for your processor from intel.com.
  • Try running Ubuntu off of a live CD or a USB thumb drive for a while to completely eliminate software as the culprit.

If swapping the Nvidia card or running off of the Intel HD graphics solves the problem, it's very likely to be a failing Nvidia card (some part of it; but it doesn't really matter which part because it's not like you're going to break out a $10k+ microsoldering kit and start physically repairing the traces, are you?).

If the problem persists with the Intel HD graphics only (with the Nvidia card playing no part in the display output path), it's very likely either the monitor cable, or the monitor itself going bad.

If the only thing that fixes it is running Ubuntu, it's very likely to be a software issue -- either a bad driver, bad configuration (of display timeout, etc.), or even a virus/malware in your Windows installation.

  • Thanks! I will try all of these. Will take a while since I can't reproduce the issue on demand but now I have options. Good to know all that about TDRs, should save me a lot of time. – Mr_CryptoPrime Dec 30 '16 at 2:51
0

I've seen one more problem that can cause a somewhat similar problem. To check for it, run the computer with the side panel temporarily removed. When the problem starts, check if the fan or fans on the graphics board are still turning. If not, you might be able to fix this by replacing the fan or fans, but you're unlikely to find the right type of fan or fans anywhere other than some other graphics board of the same brand and a similar model.

0

I fixed the issue by buying a graphics card that doesn't use as much power. You would think that by paying someone to build your computer they'd at least have the decency to verify your PSU is sufficient, but I guess not. Trust no one!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.