1

I'm new to Thunderbird. I downloaded emails from a custom server and it worked fine: as TB downloaded them they were deleted on the server.

Now I downloaded some Gmail emails, and that didn't happen. They were downloaded to Thunderbird but remained on the server.

I'm using pop.gmail.com with SSL. I see no option that may be making TB not delete them.

Any idea how to make this work?

  • Thunderbird automatically sets up Gmail as IMAP accounts, if it is IMAP it won't (and shouldn't) delete them. Why do you want them deleted, the whole concept of Gmail is you never delete them, except spam, and archive everything. If you want to actually delete them, you will need to setup your Gmail account to allow POP3 email which is disabled by default, then change the account to POP3 in Thunderbird... You have to tell Gmail what to with "popped" emails. support.google.com/a/answer/6089246?hl=en – acejavelin Dec 31 '16 at 0:04
  • @acejavelin, the whole concept of Gmail is you never delete them .. actually the whole concept of Gmail is Google's e-mail .. much like YMail! is Yahoo's e-mail .. it's user choice if they want to immediately delete a message or archive it for later use .. which is the whole concept of e-mail .. – txtechhelp Dec 31 '16 at 0:18
  • Take it how you wish but Google in general is intended to archive everything, not delete it, but the link and settings changes I mentioned earlier are valid, I will give you an official answer shortly with screenshots. – acejavelin Dec 31 '16 at 0:23
2

This is actually not controlled by Thunderbird in this case, but by Gmail. By default, when Gmail is accessed with POP it will not delete messages, it will archive them... Open Gmail in a browser and go to Settings, then select the tab labeled "Forwarding and POP/IMAP", under the POP Download section, item #2 "When messages are accessed with POP" change the drop down from archive Gmail's copy to delete Gmail's copy and that should take care of it.

Gmail Forwarding and POP/IMAP settings tab

  • 1
    Thanks a lot! I did that and it worked... but I had emails from late 2014 waiting for download, and after changing the config GMail started serving all emails from 2008! O.O It was easy to delete until 2014, but then I had to clean 2 years worth of emails and separate them from those I wanted to keep. Very troubling ;_; well at least I hope it's done and never need to do it again. – Hikari Dec 31 '16 at 3:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.