0

I set up a home LAN with two routers, the second used to repeat the Wi-Fi signal of the first one in an area of the house where the signal of Router A doesn't reach. Both routers and all clients are connected through wireless connections; none of the routers has Ethernet ports.

Router A is a portable router that connects to the Internet through a 3G connection. The second router (Router B), also portable, is a wireless client of router A and also repeats its Wi-Fi signal.

Router A is a portable Huawei 3g router

Router B is a portable Hootoo Travel Mate router

The network is set up this way:

Router A

  • Connects to the Internet via 3G connection, WAN IP and gateway assigned by the ISP
  • LAN address 192.168.8.1, netmask 255.255.255.0, DHCP disabled

    Clients:

    • .30 Android tablet (media server, Samba server)
    • .20 Android phone
    • .10 Windows 8.1 laptop
    • .2 Router B

Router B (Wi-Fi bridge/repeater)

  • Connects to the Internet via Router A
  • LAN address 192.168.9.1, gateway 192.168.8.1, netmask 255.255.255.0, DHCP disabled
  • It's client of Router A with IP: 192.168.8.2 (wireless connection, not cable)
  • It's gateway for its clients with IP 192.168.9.1

    Clients:

    • Android phone
    • Windows 8.1 laptop

The Android tablet always stays on network 192.168.8.X; the phone and the Windows laptop roam between 192.168.8.X and 192.168.9.X. They have fixed IP addresses on 192.168.8.X because of a Wi-Fi backup system I have in place. The Android tablet hosts a UPnP media server (Kodi) and a Samba server.

From 192.168.9.X I can ping all machines both on 192.168.8.X and on 192.168.9.X.  I can also access the media server, even though it doesn't get automatically detected; I have to specify its IP address, I imagine because broadcast packets do not pass through router B.  I can access the Samba server through Windows shares but not by name, only by specifying the IP address of the share. That's not a problem.

From 192.168.8.X I cannot ping any machine on 192.168.9.X, but only Router B as 192.168.8.2.

I have no need of two subnets, but couldn't/don't know how to configure Router B to just extend the first network without creating a new one.

How can I configure my equipment so all my machines can talk to all other machines, regardless of their location in the house?

  • If you're stuck with the router mode (e.g. if B cannot be switched to bridge), hint: you would add a route on router A, telling it that subnet B is accessible via router B. – grawity Jan 1 '17 at 1:32
  • Thanks for the suggestion, I had thought about it, unfortunately none of the routers allow to specify routes. I might try to install openWrt. – aless Jan 3 '17 at 18:30
  • And they dare call themselves routers? – grawity Jan 3 '17 at 18:38
2

These style of routers are generally NAT routers. One side effect (which is also a feature) is that the outbound port of the router acts as a sort of firewall for the clients on the inside of the router. So yes, using the typical configuration will mean that hosts outside of router B (in this case 192.168.8.x) will not be able to see hosts inside of router B (192.168.9.x).

In general to get the functionality you are looking for, the router will need to be configured to bridge or access point mode.

  • I supposed it could be a limitation of the router. So I should replace Router B with one that can act as access point. Would it work with a wireless network only? The 3G router doesn't have any Ethernet port. – aless Jan 1 '17 at 9:40
  • The last router I bought will let you connect to a wireless only modem using bridge mode. They (Asus) also calls it WDS (Wireless Distribution System) – Stephen Rauch Jan 1 '17 at 16:01
  • NAT doesn't hurt much in this place. (Though it papers over the problem, partially, so it should be disabled.) You can still route into a NATed network. – grawity Jan 3 '17 at 18:39
  • The router performing NAT may cause results similar to a firewall, as you stated. However, that effect can often be eliminated if the other router gets a route added to point traffic to the device performing the NAT. – TOOGAM Jan 5 '17 at 6:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.