0

I have a Thinkpad x260 laptop with Windows 10 64 bit and latest Chrome. I have noticed that Chrome has big problems with displaying certain pages with large tables - it hangs for several seconds (or even minutes) before they are fully rendered. Unfortunately one of them is a website I am developing for a customer, so it is crucial for me to fix this. The pages work without problems in other browsers (Firefox, Edge, MSIE) and also in Chrome on my colleagues' computers, so there must be some problem with my setup which produces these problems. However, I cannot figure out what is happening. Here's what I have tried so far:

  • I looked on the "Timeline" in Chrome Developer Tools. When rendering one of the offending pages, it shows that many seconds are spent in idle state (but the browser is not idle at that time, it is hanging and unresponsive) and also many seconds are spent on "Other" (that's what the timeline calls it - "Other") and very little time on actual scripting and rendering.
  • I installed a virtual Windows 10 machine under Hyper-V and installed Chrome there. The pages work without any problems in the virtual machine, which confirms to me that it's my software setup that causes the problems, not my hardware.

I tried to eliminate various possible causes but nothing helped:

  • Ran Chrome as another user.
  • Disabled GPU acceleration in Chrome.
  • Disabled all plugins and extensions in Chrome.
  • Uninstalled anti-virus and anti-malware software.
  • Updated graphic card drivers.
  • Changed all the GPU- and rendering-related options in chrome://flags/
  • Tried the "netsh winsock reset" command.

I am practically out of solutions short of reinstalling Windows and all my software, but it would mean losing several days of work on setting up the computer. Therefore, I would appreciate any suggestions on where to look for the problem cause.

  • Did you try this ? cleanup-tool On the Android Chrome version, I had similar problems, it helped to clear the history completely. You did this first? – Wiffzack Jan 1 '17 at 17:00
  • Thank you for the suggestion. Yes, I tried this, but it did not change anything. It showed the message "No programs found", then it deleted cookies and some other browser data, but the pages are as unresponsive as before. – Michau Jan 2 '17 at 17:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.