10

Today I had some trouble printing, so I rebooted my PC. However, I was very surprised to find that Windows 10 wouldn't start. After clicking "Restart" it would take me to a blue screen, "CRITICAL SERVICE FAILED".

I've tried the automatic repair option, but it failed. Looking at the log file at C:\Windows\System32\Logfiles\Srt\SrtTrail.txt, it says that:

A recent driver installation or upgrade may be preventing the system from starting.

Repair action: System files integrity check and repair Result: Failed. Error code = 0x490

I've also tried booting into Safe Mode, but it would still yield a blue screen.

I've also tried some command line tools.

bootrec /fixmbr

bootrec /rebuildbcd

bootrec /fixboot

did not work.

sfc /scannow /offbootdir=c:\ /offwindir=c:\windows

also didn't yield anything useful:

Windows Resource Protection did not find any integrity violations.

Chkdsk completed successfully, but did not change anything:

X:\windows\system32>chkdsk /f C:

The type of the file system is NTFS.

Chkdsk cannot run because the volume is in use by another process. Chkdsk may run if this volume is dismounted first. ALL OPENED HANDLES TO THIS VOLUME WOULD THEN BE INVALID. Would you like to force a dismount on this volume? (Y/N)

y

Volume dismounted. All opened handles to this volume are now invalid. Volume label is Windows.

Stage 1: Examining basic file system structure ...

1212672 file records processed.

File verification completed.

9383 large file records processed.

0 bad file records processed.

Stage 2: Examining file name linkage ...

1514736 index entries processed.

Index verification completed.

0 unindexed files scanned.

0 unindexed files recovered to lost and found.

Stage 3: Examining security descriptors ...

CHKDSK is compacting the security descriptor stream

Security descriptor verification completed.

151033 data files processed.

CHKDSK is verifying Usn Journal...

35484208 USN bytes processed.

Usn Journal verification completed.

Correcting errors in the master file table's (MFT) BITMAP attribute.

Correcting errors in the Volume Bitmap.

Windows has made corrections to the file system.

No further action is required.

233434111 KB total disk space.

219701928 KB in 1055398 files.

552960 KB in 151036 indexes.

    0 KB in bad sectors.

1324039 KB in use by the system.

65536 KB occupied by the log file.

11855184 KB available on disk.

 4096 bytes in each allocation unit.

58358527 total allocation units on disk.

2963796 allocation units available on disk.

Failed to transfer logged messages to the event log with status 50.

I'm actually running out of ideas right now. I'm on the Anniversary Update.

5

After a few error messages (btTool.exe) my pc got a BSOD and rebooted. The pc was unable to boot and kept throwing a BSOD: CRITICAL SERVICE FAILURE. The only way I could boot Windows was by booting with the option "Disable driver signature enforcement". I tried a lot of things: memory tests, sfc, bcdedit options, ... . Unfortunately without luck.  I fixed this issue by doing a repair using a Windows 10 .iso and just doing an installation of Windows overriding the current version with keeping files and apps. This repair took two hours and the system is working and booting fine now.

  • 1
    This answer doesn't really explain how the author solves their problem. – Ramhound Apr 6 '17 at 19:53
  • 2
    I explained how I solved the problem... "I fixed this issue by doing a repair using a Windows 10 .iso and just doing an installation of Windows overriding the current version with keeping files and apps." So I would suggest to the author to do the same. Just giving ideas... as asked by the author. – Joeri VH Apr 13 '17 at 14:16
  • 1
    Even though this isn't a full solution, it still gives the ability to escape the boot loop and do something useful with the system. Thank you very much for this posting, this should be MUCH higher in the search results. The exact error code is: CRITICAL_SERVICE_FAILED , I notice all the other entries don't have the underscores, which may be why the search didn't find this article sooner. – Origin Jul 15 '17 at 5:52
2

I had the same issue like 20+ times. Every time I came up with a new idea of workaround/fix (like yours), I ended up Reset the Windows anyway. It was 1 month since the last time I had to Reset/Reinstall my Windows, since then I got Win 10 Pro instead of Home and I tweaked few things after the installation. Everything seems to be working, don't really want to bother find the bug because I work on this machine.

The causes can be (from my diagnostics):

  • Windows edition (Never happened to me on Windows 10 Pro)

  • (Disk Cleanup) on the main partition (I haven't cleaned after the last installation)

  • Win 10 always tried to install a driver for my fried AMD Graphics card (on Laptop, even if I disabled the specific updated with Show or hide updates, after the driver got updated, windows instantly downloaded it... so I added Hardware-IDs to the black list in Group Policy)

  • I have an integrated GPU in my i7 but that's malfunctioning, so I ended up buying a EXP GDC from china and I'm using GTX 750Ti through PCI-E with two monitor. So maybe Win 10 don't like the fact that a laptop can have a Discrete GPU.

  • (Atleast but not sure if this can cause that issue) My second monitor is my Laptop's Display. I bought a Controller-board and I connected it to my GTX.

Tweaks I've done:

  • Disabled Hardware Ids (for fried hardware), so Windows is skipping it on Update (I think it's only in the Pro edition)
  • To make sure, I delayed the Windows Update (Only Pro edition)
  • Disabled built-in Windows Defender through regedit
  • Disabled Hibernate function
  • Changed "Turn off hard disk after" Power plan's settings to never

(I will update post if I forgot something)

Edit: Happened again with Win 10 Pro but this time with Unknown bugcheck: 0x5A param 0x1 xy... (in strtrail.txt) which indicated me to driver integrity checks, I just started with custom startup without integritychecks, and disabled it in the bcdedit

bcdedit /set nointegritychecks on

(p.s.: this is not a good solution, but I can't set it to skip for a specific driver which is causing the integrity check to fail)


final Edit: For the best solution, DO NOT run Disk Cleanup on main drive or create restore point before you run it on main drive (tested it, and it's wipe out drivers when you pick "Temporary Files" option and will cause Critical service failure / BSOD on next OS startup).

[OS Build: 15063.296]

  • Have you reported this to Microsoft? – rolls Jun 27 '17 at 22:58
  • Sorry, but your "best solution" is not a solution. I preferred your previous answer as it gave more useful info. I can confirm that in the last 72 hours I did perform a disk cleanup, and perhaps related to the OP, I also had printing issues which caused me to reboot. Printing issues: I could not click "Print" when selecting any usual printers in the standard print dialog, and Office had trouble rendering the print preview. The only printer that didn't have trouble was the "Print to OneNote" virtual printer, which had mysteriously been set as default. Reboot and BOOM! Hit with this error. – pcdev Jun 29 '17 at 1:39
  • Additional information as I've been diagnosing the issue: I'm using Win 10 Enterprise for reference, boot logging does not log anything, no log file is even created before the crash. – pcdev Jun 29 '17 at 2:33
  • 1
    Temporary workaround to get you booting (not a fix): From Automatic repair screen - Advanced options > Troubleshoot > Advanced options > Startup Settings > Restart This will get you into the advanced boot menu, then choose Disable driver signature enforcement (Credit to dodocss on this thread) – pcdev Jun 29 '17 at 2:37
  • Final comment: I can only surmise that indeed the Windows cleanup was at fault. My purpose for the cleanup was to free up space, particularly get rid of the huge Windows.old folder after the Windows 10 Creators Update. I think removing that broke stuff - perhaps stuff was soft-linked back to the .old folder, I don't know. Anyway @JoeriVH's solution is going to be my solution sadly - repair keeping files. – pcdev Jun 29 '17 at 4:29
1

Temporary Solution to take backup of important data from C:/ drive:- follow this to get you booting (but its not a fix): From Automatic repair screen - Advanced options > Troubleshoot > Advanced options > Startup Settings > Restart This will get you into the advanced boot menu, then choose Disable driver signature enforcement

0

Since you've been able to use the command line and other tools, it seems you've done a thorough job booting from alternative media (USB? CD?).

At this point, I would suggest downloading the latest Windows 10 build and try repairing your OS during the installation process, after first backing up the disk, lest installation mung things further. If repair fails, do the full installation.

  • How would I "repair" the OS? If I run the installation process, wouldn't I be reinstalling everything? – jacobz Jan 2 '17 at 0:07
  • Usually, there is an option on booting the media to repair (or to update) an existing Windows 10 installation or to do a complete installation. Lately, even the cumulative updates do almost a complete reintallation of the OS. – DrMoishe Pippik Jan 2 '17 at 0:52
  • Won't work. "Repair Install" option requires starting it in a running version of W10. – Conrad Apr 13 '17 at 19:33
0

what worked for me .. From Automatic repair screen - Advanced options > Troubleshoot > Advanced options > Startup Settings > Restart This will get you into the advanced boot menu, then choose Disable driver signature enforcement F7 on the windows 10 laptop and pc both dell

then goto the power button bottom right , this will display apply updates apply them and wait , the device may reboot a few times but should get you to a logon screen if it works

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.