2

I am currently using VMWare Player 12 (free edition) on Windows 10 Pro x64 as host and guest system, and a Logitech M510 mouse as input device. My problem is that inside the guest-system, my "side" buttons (forward and back) do not work in any program.

I already googled for similar problems, and found out that some additional entries in the VMX-file are necessary:

usb.generic.allowHID = "TRUE"
mouse.vusb.enable = "TRUE"
mouse.vusb.useBasicMouse = "FALSE"

However, even when I add these settings, the additional buttons do not work, so I guess VMWare must have changed something additional.

Does anybody know a solution to this in newer versions of VMWare Player? I found a similar thread at the VMWare forums concerning the latest version of VMWare workstation, without a solution, so I guess this affects the latest player and workstation versions unfortunately.

  • Did you fully power-off the virtual machine and power it back on after making those changes to the .vmx file? Those settings should allow the mouse to connect to the VM as a USB device (which would allow all buttons to work, provided that any necessary device drivers are also installed in the guest). – jamesdlin Jan 5 '17 at 3:39
  • OF course I completely shut down the VM, I always do when making changes to the VMX file. It didn't work anyway unfortunatley. – Erik Jan 5 '17 at 8:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.