8

I have an HP Pavillion 14 laptop. Intel Celeron 1.6GHz 2 core. 2Gb RAM. Windows 10.

It's running really slowly. So slow that its unusable right from the very start. I check the resource monitor and the CPU never goes above 30% utilization or 0.48GHz. It's like its been capped at 30%, it goes below, but never above. I'd have expected it to be working a lot harder than that.

I've tried

  1. Uninstalling all unnecessary programs (antivirus, various preinstalled HP applications)
  2. Changing the power plan to maximum power on both battery and plugged in
  3. Running a system check (by pressing F2 when the computer turns on). Nothing was found.
  4. Checking for updated processor drivers via Device Manager. None found.

Any ideas?

6
  • change power plan to high performance. can the cpu be now be used more? – magicandre1981 Jan 4 '17 at 16:21
  • @magicandre1981 I tried that and didn't make a difference (similar to point 2) – Kevin Brydon Jan 4 '17 at 16:45
  • also try to reset the power plan to the default settings. Maybe you or a software changed/corrupted the plan – magicandre1981 Jan 4 '17 at 16:47
  • Change your power cable. That's what fixed it for mine. – Dan Apr 12 '17 at 21:52
  • Percentage of CPU usage doesn't work like you think it does. 30% cpu usage isn't .48 GHz unless you mean Windows is reporting the frequency of the clunis .48 GHz (which would mean your CPU is throttled due to extreme heat). Processor drivers don't exist (so what exactly did you install?) – Ramhound Apr 12 '17 at 23:15
13

I had the exact same problem. If I went under Task Manager > Performance, I found that CPU usage would not go over 30%, and the Speed was clocked down to 0.78GHz.

At the bottom of the Performance tab there is a button to Open Resource Monitor. From here I found that Maximum Frequency was capped at 30%. (This should instead be showing at about 100%). This defines the maximum speed percentage which Windows will allow the CPU to run at.

Click for screenshot of Resource Monitor

I tried adjusting everything within Windows Battery and Performance settings that I found here and on other forums, but to no avail.

I finally found that I needed to prevent the "intelppm" service from starting (and subsequently malfunctioning), using the registry. This may especially be the case when slowness occurs on Laptops which are currently plugged in.

To do that:

  1. Simultaneously press the Windows image + R keys to open the 'Run' command box.
  2. In run command box, type regedit press Enter to open the Registry Editor.
  3. At the left pane, navigate to the following registry key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\intelppm

At the right pane:

-Double click the "Start" key.

-Modify the value data from '3' to '4'

-Click OK.

-Restart the PC

After that the CPU was no longer being clocked down to a low speed, and the Maximnum Frequnency under Resource Manager now shows as 100%.

2
  • I could totally understand your guidance and I like your solution, but for me it doesn't help. Maximal frequence still 30 %. – Mar Tin Feb 9 '20 at 16:40
  • I did this, and the percentage indeed went up to %100, but it was still running just as slow as before. – user262055 Apr 21 at 3:38
10

I had exactly the same problem at a client today with a Windows 10, Dell Celeron Laptop.

The machine took almost 30 minutes to open Outlook and was terribly slow in general.

The CPU ran at 30% maximum utilization, at 0.48Ghz PERMANENTLY, every day.

I noticed at the right bottom of the screen that although the laptop was plugged into power, the battery icon said "not charging" and battery level was 1%.

To resolve it, I did the following (perhaps this could work for you too):

  1. Double-click the battery icon (not right-click) at the right-bottom of the screen (in the tray)
  2. Click "Battery Settings"
  3. Untick the option for: "Turn battery saver on automatically if my battery falls below..."
  4. Disable the setting: "Battery saver status until next recharge"
  5. Unplug the charging cable and re-plug it into the charging port of the laptop.

The battery icon at the right bottom of the screen should now change to "Charging".

After this the CPU started running at 100%, 2.48Ghz and the machine worked well again.

For good measure, click on the battery icon again and set the power mode to "Best Performance"

Note: I noticed that all the battery settings for "Pressing the Power Button", "Pressing the Sleep button" and "Closing the lid" were set to SLEEP. So I guess that every day when the client went home, he closed the lid and put it in his laptop bag. This totally drained the battery, and because the setting was enabled to use Battery Saving when power dips below 20%, every morning the laptop would be SUPER slow.

Whether the Battery Saver setting disabled the battery from charging I can't say for sure.

To avoid the problem for this client, I changed most settings to "Shutdown" and some to "Hibernate"

1
  • Mostly the same for me (Alienware). Except, once I unplugged it, it instantly when to 100%. Continued fine after plugging back in. I think the thing to look for is the non-charging even though it's plugged in. – Sam Dean Jan 19 at 4:36
2

It could be that your computer is under-clocking - specifically it may have a problem with heat build up. Have you attempted to clean the air intake fan ? Is the fan spinning ?

Its also possible that the computer is bottlenecked (low memory, slow drive?) and thus is spending a lot of time waiting on IO so the CPU is down-clocked. In that case, you would want to remove the IO bottleneck. You may want to download specific software designed to max out the CPU but use little other resources to test this - Software like "Prime95" would help here - you need to ensure the number of threads you run it on is at least equal to the number of CPU cores you have.

2
  • Along these lines, I would suggest installing a stress program like Prime95 to make the CPU work as hard as it can. Second, I would install Speccy or another program that reports the CPU temp on a graph. It may be that your CPU is overheating and throttling itself down. – Christopher Hostage Apr 12 '17 at 23:35
  • This issue occurs when you try to run a test or anything else. when you try to run a stress test it's capped at some small arbitrary percentage and the clock rate doesn't change from what it boots at. In my case 0.78Ghz – Douglas Gaskell Dec 10 '20 at 6:38
0

I have Acer One 14, I also have tried change power plan, disable battery life saver and other thing but not working.

Then I found CPU+ icon below F2 button.

When I press fn + F2 my laptop started running to 100% again.

Not the answer you're looking for? Browse other questions tagged or ask your own question.