1

i have an IIS web server installed on windows server 2012 R2, the problem is that when i try to open the http://localhost page from the windows server 2012 it fails and displays (explorer cannot display this page), while when i try to access the welcome page from a remote machine it works fine.

Any ideas about the cause for this issue? Thanks

0

Make sure the bindings for the website are correct. https://www.iis.net/configreference/system.applicationhost/sites/site/bindings/binding

  • Thanks for your reply, The binding settings are as default for the default web page that comes with IIS, also as i mentioned above the issue is on server side only, from client side i can see the welcome page. – Alaa eddean Jan 4 '17 at 12:23
  • What happens if you ping localhost on the server? – Webbanditten Jan 4 '17 at 12:27
  • It replies with the IPv6, but i also tried to use 127.0.0.1 and the same issue happens. – Alaa eddean Jan 4 '17 at 13:02
  • Interesting, maybe something in this answer will work? serverfault.com/questions/787320/… – Webbanditten Jan 4 '17 at 13:07
0

Update, The problem was fixed, it was an issue with the internet explorer security settings itself, had to remove localhost and 127.0.0.1 from the local intranet zone to the trusted sites zone (Internet Options > security) and the problem was fixed.

Many thanks all for your much appreciated replies.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.