I have a Asus x550ze laptop. This laptop shows me a blue screen and after many searches I found that I must update the BIOS to solve this problem. However, my laptop doesn't have a battery and I always use AC Power.

I have tested many ways and searched many sites but I cannot find a solution for update bios without battery.

winflash.exe didn't help me because this application shows me an error for battery and when I run it from cmd by using /f or /forceit it show me another error like "file can not find".

I downloaded the afudos for updating bios from MS - Dos But it not work and show me error like this : file creating error or file not found.

Does that mean that if anybody loses his laptop battery one can't use his laptop anymore?

Update :

I need update bios for solve bluescreen that shows a error for driver of graphic and i installed latest driver from asus site but i find out this problem comes from bios and i must update it

  • When does your laptop shows you blue screen: straight from the boot or after some time during the usage of the machine? Have you tried looking for the official BIOS updates on the Asus website asus.com/Notebooks/X550ZE/HelpDesk_Download? Jan 6, 2017 at 1:58
  • A battery is REQUIRED to update the BIOS on most notebooks, what don't you understand about that? In most notebooks you cannot override this in any way (and I cannot find a way for newer Asus devices)... Buy a battery, they are like $14 on Amazon for the X550. Also remember that "newer" devices like this don't have plain old BIOS like the old days, they use a UEFI firmware which although it does many of the same things it is different, I wouldn't be fooling with WinFlash or other 3rd party tools unless your ready to deal with a bricked laptop.
    – acejavelin
    Jan 6, 2017 at 3:07
  • @acejavelin i can't Buy new battery because my laptop can't detect the battery because i fixed my mainboard problems by cutting the battery cable from the mainborad
    – sam nikzad
    Jan 6, 2017 at 11:53
  • @alljamin i'm saying about flash bios without battery . are you sure read my question ? i could find bios files from asus and it was't my problem
    – sam nikzad
    Jan 6, 2017 at 11:55
  • @AbbasNikzad Honestly, then your out of luck... If the system can't detect a battery then you can't update the bios.
    – acejavelin
    Jan 6, 2017 at 13:46

1 Answer 1

  1. Download the new bios (for me X75A1AS.412) and copy it on USB key (FAT32).

  2. Start and enter bios, then in bios menu : "Advanced" -> "Start Easy Flash"

  3. When the system will display that you can not update the bios because there is no battery, on your keyboard you enter "risky"

upgrade BIOS on Asus without EasyFlash and WinFlash

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .