0

For some strange reason, all the icons on my desktop accessing websites became 'Microsoft Edge' when I switched from Chrome to Edge for one browsing session! I tried everything to get rid of it, but no luck! Also, when I want to make Mozilla Firefox my default browser, as soon as I click OK, an 'Edge' page comes up thus nullifying my preference! Apparently, Microsoft has a wired software app overriding one's choice? How can I disable it or get rid of it so I can get back my browser of choice?

  • It would be easier to just just the default browser back to your original selection. Removing Edge WILL NOT solve your current problem by the way. – Ramhound Jan 4 '17 at 22:39
  • He's probably getting the "something wrong with your default browser" message when trying to switch defaults. – Daniel B Jan 4 '17 at 22:47
  • This is because Windows 10 has the most ridiculous way of changing your default browser. You can see how to do it here. – DrZoo Jan 4 '17 at 22:59
  • @DrZoo To be fair the process hasn't really changed. You also set the default browser the same way, how it looked has changed, but you intentially perform the same steps – Ramhound Jan 4 '17 at 23:27
0

windows 10 requires you to choose your default browser in the settings area of windows - (you can no longer just 'set this browser as default' within the browser application

go to settings/ system / default apps - and you can choose what you use under "web browser" heading

Note - edge is also the default pdf reader in windows 10 too..

  • 1
    How about more specifics? How does this differ from the duplicate questions answer? Besides the fact is less detailed. – Ramhound Jan 5 '17 at 0:07

Not the answer you're looking for? Browse other questions tagged or ask your own question.