Since this morning, I have a weird problem with my Remote Desktop connection.

When I connect, Everything on the screen that hasn't had an update for a while becomes blurry. When a screenupdate takes place, the graphics or text becomes sharp and readable again, but fades out to a blurry version in a matter of seconds. It takes about 10 seconds for the text to become somewhat blurry, another 10 seconds to get very blurry.

Here's a screenshot I took that shows how bad it is. And no, the image has not been resized, its what I really see.

I've tested that this only happens when I RDP into a Windows 10 environment. I have RDP'd into several Windows Server 2008R2 and there are no problems. It does not happen to a 2011 SBS server either. Don't know about 2012 as I currently can't test that. One of the RDP Windows 10 environments is inside my network, where others are outside. I've rebooted one of the destinations and my own pc.

Any idea how I can fix this?

enter image description here

  • 1
    Go to remote desktop, options, experience and uncheck desktop composition. Another try: social.technet.microsoft.com/Forums/de-DE/… Commented Jan 5, 2017 at 9:52
  • I haven't changed any of my settings. It started happen suddenly. Also, Desktop composition and fonth smoothing are disabled, changing these settings have no effect.
    – LPChip
    Commented Jan 5, 2017 at 10:03
  • can you please also share the following: 1) OS SKU (Home, Pro, Server) 2) OS build (if you are part of the Windows Insiders) 3) what type of GPU you have (both server and client) 4) is either of the machines domain joined (this might be affected by group policies).
    – cdavid
    Commented Jan 5, 2017 at 18:23
  • @cdavid I already solved the issue. I have to wait for 2 days before I can accept my answer though...
    – LPChip
    Commented Jan 5, 2017 at 19:45

3 Answers 3


Just to clarify, the setting is located within Intel HD Graphics Control Panel on your host machine.

Intel HD Graphics Control Panel

  • 1
    Completely forgot to mark this as answered. Given you took the time to post an image too, I'll reward it with a +1 and check. :) enjoy.
    – LPChip
    Commented Feb 10, 2017 at 22:57
  • Thanks! Originally when I read this post, I though that the problem was with the drivers of the machine I was connecting to (via RDP) but when I realized that this setting was actually related to my own workstation's Intel drivers I decided to post this answer as a clarification...
    – Dan
    Commented Feb 14, 2017 at 18:45
  • 3
    It seems this doesn't work anymore, 10th of Jan 2019 :( It's already off, but it doesn't change anything, apparently it's per app now, not globally.
    – Timotei
    Commented Jan 10, 2019 at 12:13
  • @Timotei I had the same issue. Installing the latest drivers from Intel for HD 4400 ( didn't help either. I then installed the Microsoft Remote Desktop app from the Store and here the issue does not appear.
    – letmaik
    Commented Feb 4, 2019 at 10:18
  • @Timotei any news on this?! Commented Aug 19, 2020 at 21:59

Apparently Intel had updated my graphics drivers.

the link @duDE posted has the following text:

If you are using Intel HD Graphics, try opening the Graphics Control Panel
(right-click the desktop and select Graphics Options), then go to 3D and 
Turn Off "Conservative Morphological Anti-Aliasing. I was having a similar 
issue and this fixed it for me.

This setting was now enabled. Disabling it, then reconnecting fixes the issue.


This solution may help you.
Connecting with Remote Desktop, the fix seems to be to disable Persistent bitmap caching under Show Options >> Local Experience.
Link: https://superuser.com/a/1561610/1887321

Update: Unfreeze RDP by running CMD

  • Step 1. Search "cmd" in the search box and then right-click the option and choose "Run as Administrator".
  • Step 2. Type the following command line:
reg add "HKLM\software\policies\microsoft\windows nt\Terminal Services\Client" /v fClientDisableUDP /d 1 /t REG_DWORD
  • Step 3. Reboot the PC and check whether RDP freezes still.
  • Congratulations posting an answer to a 7 year old question that has long been solved since.
    – LPChip
    Commented Feb 2 at 18:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .