22

My taskbar does not stay on top of applications, even when they are not full screen. As you can seen in the cropped screenshot below, the non-maximized windows are on top of the taskbar.

A desktop screenshot showing two windowed applications covering the Windows taskbar with a third window maximized and not covering the taskbar

  • All applications are showing up on top of the taskbar, not just a specific application, such as Microsoft Word
  • If I maximize a window, it does size correctly - the bottom of the maximized window touches the top of the taskbar

In my googling, I've only found instances of people trying to go the other way (they want to disable Always on Top), or people talking about the taskbar being on top of full screen applications such has video games or movies. I found that the ability to toggle "Always on Top" was removed in Windows 7 and the behavior should be that the taskbar is always on top, but that is not the behavior I'm getting. I can't think of any application I may have installed that would change this behavior.

The closest SuperUser question I can find is this one, but the solutions there didn't work for me.

8
  • Are you using any display-changing plugins or applications. Things like alternate start menus or the like? – music2myear Jan 5 '17 at 23:49
  • Did you check this post? – Asme Just Jan 6 '17 at 1:30
  • @music2myear I couldn't think of any, but I may need to review my "Programs and Features" list to see if I've forgotten about anything. The last answer in the post I linked to listed a couple of applications, but the last bullet was something like "or it could be any application, really" :/ – tehDorf Jan 6 '17 at 1:37
  • @AsmeJust I checked out your link, but I don't see how it is relevant. My taskbar is not set to Auto-hide and I do want it to be always on top. Did you misread my question? – tehDorf Jan 6 '17 at 1:42
  • 1
    Well, Windows 10 as SOOO many weird behavior I never saw in Windows 7 or even in Windows 8. – Asme Just Jan 6 '17 at 1:47

14 Answers 14

11

Ok, so I fixed this for myself just now. All I did was right click the task bar, go to properties and set it to show at the top of the screen. Then I set it back to the bottom and now it works like it used to.

4
  • 1
    You might add more detail, screen shots, etc. of what you did as it does not seem clear based on reading this answer. – Pillsbury IT Doughboy Jul 12 '17 at 0:53
  • Welcome to superuser: While this answers the question,(you need to accept it) it would be a better answer if you could provide some explanation why your solution works with detail and an easy to follow instructions. If you feel your answer is correct do these things and re-edit. Please take a couple of minutes and read:- superuser.com/help .Answering: superuser.com/help/how-to-answer, again welcome to superuser.Thankyou – mic84 Jul 12 '17 at 1:42
  • 1
    Right click the taskbar, go to Taskbar Settings, change "Taskbar Location on Screen", then change it back. Worked for me. – mbomb007 Jun 3 '19 at 19:30
  • Note that simply dragging the taskbar to a new location and back did not work for me. I had to actually right-click the taskbar, go into Taskbar settings, and change Taskbar Location On Screen to fix this. – Mike Apr 6 at 17:58
3

Had exactly same issue, mine was caused by Nvidia shadowplay desktop capture, turn it off

1
  • thanks ya turning off in-game overlay in nvidia experience fixed this for me – Rakka Rage Feb 16 '18 at 15:32
3

Pires Dimmer caused this problem for me. Turning it off fixed the issue. https://www.nelsonpires.com/software/dimmer/

1
  • Wow! This is insanely obscure but fixed it for me (well, almost: except I love dimmer so will just have to live with it). – neuronet Jan 10 at 14:23
1

I had to restart Desktop Window Manager as I noticed it somehow used 20% of an 1080 ti. That fixed it for me.

1

I've had this issue before many times and it drives me crazy.

Whenever you start having the issue, open Task Manager, and look for "File Explorer", just click on it and press restart in the bottom right. It's not a permanent solution, maybe even restarting the computer after restarting file manager would do something for you.

2
  • 1
    You may want to try ending the process of DWM [Desktop Windows Manager), of which will cause a desktop redraw to occur. That's more preferred to restarting Explorer, as doing so also ends many processes that were started by Explorer at login, of which are not restarted automatically following a restart of Explorer. – JW0914 Jul 12 '17 at 4:19
  • I believe you meant "Windows Explorer" (which operates the TaskBar). But in any case, this did not resolve it for me. – kmote Sep 27 '17 at 15:51
1
  1. Right-click on a blank part of the Taskbar.
  2. Open "Taskbar settings"
  3. Turn off "Automatically hide the taskbar in desktop mode"
  4. Turn off "Automatically hide the taskbar in tablet mode"
1

I finally figured out why the Windows 10 taskbar doesn't stay in the foreground as I would like!

Some application when running in compatibility mode causes any other application window will be able to overlay the taskbar. When closing this application, task bar will work fine.

I'm a software developer and my development application, because it's old, works better in compatibility mode. Interestingly, this behavior of the taskbar did not occur with Windows 7, where it was always in front of all other windows.

Anyway, check if a program is running in compatibility mode and try to disable it to see what happens.

0

Incase more people still have this issue.

Quite often I find that simply right clicking an empty space on the task bar fixed this.

Minimise all but 1 window / program and move / change the height so that it covers half of the task bar, then hover over the task bar and right click on the bit you can see, for me this fixes it 9 times out of 10.

I noticed the issue usually occurs if explorer.exe has crashed or had an accident.

Another potential option is to open task manager and kill explorer.exe and then restart it. Sometimes has to be done a couple times.

0

FIXED for me - I noticed the bottom few rows of pixels were missing off the bottom of the screen. The mouse was stopping at the last row of pixels, not disappearing down to where the taskbar would be. There was apparently a problem with my screen resolution or registration.

I changed my screen resolution, then changed it back to the recommended setting (native resolution) and my taskbar is now accessible!

0

I have used the option Cascade Windows. on the tool bar menu and it worked. the toolbar is under the application.

0

In my case, the problem was caused by an add-in for Outlook 2016. After disabling the Outlook Addin the behavior did not occur anymore. The problematic Addin was Colligo Engage.

You can disable the Addins in Outlook in the options under the tab "Add-Ins". For troubleshooting - If you experience the same error, I would try to close all programs (also the Windows Startup programs) and check if it works or not.

0

This happened to me, I did the taskbar config, still no help.

It was one app that was in "full-screen mode" by accident I guess. I got it out of full-screen mode and my taskbar was back. This was for GitKraken (Ctrl-Shift-F or menu option), obviously, if you have some other app in full-screen mode by accident, the way to get out of full-screen mode will vary.

-1

I had this problem with Task Manager. When you dragged the window around the screen it would be on top of the taskbar

To fix: open task manager -> Go to options (top left next to "File") -> untick option "always on top".

Not sure if I did this myself or if it was always on

-2

Here's how I solved it, hope it works for others who couldn't fix it by right clicking on the Taskbar and blocking it. You must go to your Task Manager (CTRL-ALT-SUPR) and finalize the Explorer item, mine didn't have the option of restarting so I just restarted my computer after that. Took me two days to work it out X-D Good luck!

Not the answer you're looking for? Browse other questions tagged or ask your own question.