1

I have opened a ssh session to remote computer using

ssh root@<ip>

I tried to run some program on remote machine. e.g.

tail -f /var/log/log.txt

But when i press ctrl-c or ctrl-z that program is not killed/suspended. I couldn't able to get control out of that process in terminal.

  • @Bungicasse tried that now, still not able to kill – akshay Jan 7 '17 at 14:39
  • Does the tail -f continue to output data? It may be that the terminal session crashes (either some sort of remote timeout or pipe issue) – stuts Jan 9 '17 at 14:20
  • @stuts yes tail is still running. If i login to another session and kill tail, i can access the terminal – akshay Jan 9 '17 at 14:31
  • What OS are the source and destination systems? Does this problem effect all user accounts? I'm wondering if there could be a custom terminal/shell profile or something that overrides shortcuts on the destination system. – stuts Jan 9 '17 at 14:34
  • @stuts source is redhat linux and destination is QNX PPC. telnet session is working properly – akshay Jan 9 '17 at 14:42

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.