1

I just upgraded my FreeNAS to 9.10 so as to take advantage of the features in the newer version of Samba that allegedly lets Final Cut Pro store its library over SMB. However, while I can get AFP to work just fine with the Mac, I can't connect to the SMB shares.

In both cases, I have guest access disabled. I created a user account on FreeNAS and can authenticate just fine to it when using AFP. Once I turn on SMB, Finder (correctly, I believe) replaces the AFP share listings with SMB ones. However, when I try to load the SMB share by clicking on my server's entry in Finder, it says "Connection Failed" and hitting "Connect As..." reports:

The operation can't be completed because the original item for "Photo_Vault" can't be found."​

I don't see anything amiss in my settings, but can you point me in the right direction of where to even begin debugging this.

I've tried limiting which versions of SMB will be allowed to connect to see if forcing a newer version would help (SMB3 or higher), but that only seemed to make things worse, resulting in this message instead:

There was a problem connecting to the server "beatrice".

Check the server name or IP address, then try again. If you continue to have problems, contact your system administrator.

Incidentally: Zeroconf seems to be working fine. When I turn off SMB and use AFP, Finder connects just fine; additionally, if I try to connect directly to 192.168.1.30, it fails just the same as using the Zeroconf entry (beatrice.local). I can access the other network services on the FreeNAS just fine (web admin interface, AFP, etc.), whether I use "beatrice.local" or the IP address.

UPDATE: Testparm -s didn't report any errors. Here is my configuration file (which should be the default one from FreeNAS, I haven't edited it). Note that it includes the restriction on which SMB protocol should be used I referenced above; I've tried it both with and without that.

[global]
server min protocol = SMB3
server max protocol = SMB3_11
encrypt passwords = yes
dns proxy = no
strict locking = no
oplocks = yes
deadtime = 15
max log size = 51200
max open files = 231347
logging = file
load printers = no
printing = bsd
printcap name = /dev/null
disable spoolss = yes
getwd cache = yes
guest account = nobody
map to guest = Bad User
obey pam restrictions = yes
directory name cache size = 0
kernel change notify = no
panic action = /usr/local/libexec/samba/samba-backtrace
nsupdate command = /usr/local/bin/samba-nsupdate -g
server string = FreeNAS Server
ea support = yes
store dos attributes = yes
lm announce = yes
hostname lookups = yes
time server = yes
acl allow execute always = true
dos filemode = yes
multicast dns register = yes
domain logons = no
local master = yes
idmap config *: backend = tdb
idmap config *: range = 90000001-100000000
server role = standalone
netbios name = BEATRICE
workgroup = WORKGROUP
security = user
pid directory = /var/run/samba
create mask = 0666
directory mask = 0777
client ntlmv2 auth = yes
dos charset = CP437
unix charset = UTF-8
log level = 1

[Photo Vault]
path = /mnt/TheVault/Photo Vault
printable = no
veto files = /.snapshot/.windows/.mac/.zfs/
writeable = yes
browseable = yes
vfs objects = zfs_space zfsacl aio_pthread
hide dot files = yes
guest ok = no
nfs4:mode = special
nfs4:acedup = merge
nfs4:chown = true
zfsacl:acesort = dontcare
  • show us your SMB.conf. are you able to hit the shares from a windows box (just to test that SMB is actually working). I don;t know if freenas ships testparm but try sudo testparm -s to see if it indicates any errors in your smb.conf file. – Frank Thomas Jan 6 '17 at 17:53
  • I'm using this combination in a mixed Mac/Windows network, there's no inherent prblem. Testparm - s works on the console. – LotPings Jan 6 '17 at 18:28
  • Thank you, @FrankThomas. I've updated my post with the smb.conf. – Timothy R. Butler Jan 6 '17 at 21:07
  • first thing I'm noticing is that your share name does not have an underscore in it, but your error message does. have you tried sharing it as [Photo_Vault] instead? how about the user account you are using? have you run smbpasswd to set the password for samba (though I must admit, I'm not certain that that is still necessary these days). – Frank Thomas Jan 7 '17 at 6:55
1

Set server min protocol = SMB3_00 instead of SMB3. (SMB3 defaults to the newest protocol in the SMB3 family, which isn't supported on macOS Sierra.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.