6

This happens on both my Windows 10 systems, a late 2012 iMac and a custom-built PC using an ASRock Z170 motherboard and an Insignia Bluetooth dongle.

When using either Discord or Mumble and either Apple AirPods or a Bose QuietComfort 35 headset, I cannot hear sound from any other application unless I set the output device to the "Hands-Free Device" instead of the "Stereo Headphones" device.

The problem with that is the "Hands-Free Device" has only one sound quality option, 8 KHz, which is nowhere near the 44.1 KHz default of the "Stereo Headphones" output device. When I select the "Stereo Headphones" device the sound is great, until I open either of the mentioned voice chat applications, whereupon I can't hear anything until I close that program. Also, my mic does not work unless I re-set the communications device or default device to the hands-free option. If I set the hands-free device as the communications device, everything in the voice chat app works, but no other program has any sound.

I believe this is because the "Hands-Free" and "Stereo Headphones" devices are two separate Bluetooth services, and the Hands-Free device is activated whenever the voice chat is engaged, and remains that way until the "call" is over. I realize the "Communications" tab in the sound control panel is supposed to fix this sort of thing, but it changes nothing in this scenario.

Any ideas?

EDIT: I've read the suggestions in this post, which I just discovered, and none of that works:

  • Removing the Hands-Free Telephony service removes the mic.
  • Changing the "Exclusive Mode" setting on any playback or recording device does not resolve the problem. Sometimes it does temporarily, then it reverts back to the problem described above within 5 minutes or so.
  • Disabling audio enhancements does nothing.
  • 1
    Hint: I remember that there seems to be an option in win7 to reduce/turn-off other sounds whe you receive a call. – RogUE Jan 8 '17 at 7:29
  • Sorry, should have mentioned I tried setting that to "Do Nothing" and that did not help. Thank you though! – Tohuw Jan 8 '17 at 7:39
  • When discord connects, my audio device for disdcord switches from "Stereo" to "Hands Free". The other applications keep outputting on the (now ignored) stereo channel. For me the trick is to change audio device (Speaker in system tray, audio device name @top of dialog - select hands free) after connecting the call.. – Basic Apr 8 '19 at 18:54

12 Answers 12

8

This annoying behaviour is caused by limited Bluetooth bandwitch when using both mic+headset channels. It's quite well explained here: https://www.howtogeek.com/354321/why-bluetooth-headsets-are-terrible-on-windows-pcs/

Here's the salient part for your issue:

Technically, when you’re just using the headphones as a sound output device, they’re using the A2DP Bluetooth profile, and ideally using AptX for maximum sound quality. When you need the microphone, they’ll use the headset profile or hands-free profile (HSP or HFP). This allows for both recording via the microphone and playback via the headphones, but the headphone sound quality is terrible when using HSP or HFP.

If you’re just using a Bluetooth headset to take a phone call, that might be fine. If you want to speak into your headset’s mic while listening to music, playing a game, or watching a video on your PC, you’ll be frustrated.

For a PC headset with an integrated microphone, Bluetooth is a terrible choice. You’re better off getting a wired headset, or even just getting a separate microphone.

Bluetooth 5.0, which has already been announced, offers much higher bandwidth. This should let future Bluetooth headsets play back audio at high quality while the microphone is being used, in theory.

  • 1
    Please add pertinent information from the link you provided into the body of your answer. If someone comes across this in the future and that link is dead, this answer helps no one. – Andrew Nov 8 '18 at 0:13
  • 1
    I suggested an edit with a key quote from the article. @j.s.estevan is correct: what I want isn't possible. In lieu of another better answer, I'm marking this as the answer and hope my edit is reviewed through so this will help others. – Tohuw Nov 23 '18 at 16:40
3

You need a new headset.

If you open up the sound settings you'll probably see something like this (image taken from the link in OP)

enter image description here

Notice the bottom check mark is Stereo, and the phone icon is Hands-Free. For microphones like this, Hand-Free also uses Mono playback, which typically sounds bad. It can only use Mono/Voice/Hands-Free or Stereo (no voice) at one time. If an application can use voice, it will typically turn off stereo but Mono won't work, and the sound will cut out. You need to set Hands-Free/Mono as default, and deal with the poor sound quality.

I am not sure if this is a problem with all bluetooth headphones or only ones with built-in microphones. I have bought 2 different headsets off amazon and they were both setup this way.

  • 1
    Oh man don't tell me that you're right. Because i think you are, currently i can choose 1 either Good Sound and no voice or the Hands-Free with horrible sound and voice. I'm using Sony MDR-1000x – Cristian E. Aug 27 '18 at 16:54
  • This is a partial answer. Bluetooth headsets cannot do what I want them to do, per @j.a.estevan's answer. – Tohuw Nov 23 '18 at 16:43
1

So better late than never, because I had the same issue and just solved it:

  • Hit the windows key and type control panel and hit enter.

  • Go to “Hardware and Sound” -> “Devices and Printers”.

  • Select your device and right-click, open “Properties” and go to Hardware.

I saw that my bluetooth headphones had multiple entries for hands-free.

  • Click one having to do with hands-free, click properties, then change settings.

  • Click driver, and choose disable device. Do this for all entries you have for hands-free.

Once this is done, restart the computer. Once it restarted I could now use the headphones like I wanted them in the first place.

0

This might be late but I got mine working by going doing the following:

Control Panel > Hardware & Sound > Sound

A popup window should appear where you can find all the sound components of your device. Now do:

Click on Bluetooth hands-free Audio > Set as default Communication Device

Clicking on Test option should produce a sound by now.

  • That's exactly what I did, and this doesn't solve the problem. If you open an application using voice chat, as I described, you will not hear other applications' sound. – Tohuw Nov 23 '18 at 16:35
0

This works for discord(at least for me). You need to set the output on discord to headphones(not headset) and to set headphones as default in sounds.

0

I have the Bose Quietcomfort and solved the problem by using the cord that connects the headphones to the computer. When using Bluetooth I could only manage to chose between chat or game sound.

0

For what it's worth, I had the following on Windows 7: Activating both 'listening to music' and 'forward voip calls' enabled music and had the other side hearing me but not the other way around. Activating only 'forward voip calls' allowed me to have a normal phone call.

Sound quality in voip is not all that great (for the other side).

0

Here is how I get by: Set the default communication device as the hardware microphone and the output device as Bluetooth stereo for all applications manually. If your using windows 10 this is easily done in the settings application under advanced sound. I don't know the equivalent for previous windows OS.

0

solved the problem by plugging and using the mic from an old headset and use it as a mic only.

-1

Change the default device used by your communication programs. Skype caused a similar problem for me until I changed it's default device

  • Change it how? This isn't a helpful answer. See @j.a.estevan's answer: what I want isn't possible. – Tohuw Nov 23 '18 at 16:41
-1

click in the bottom righ on volume icon then sounds and basically change your main head set to defeaul communication device by right clicking and the hand free one to default device and should work

  • That's exactly what I described doing in the post. This is resolved by @j.a.estevan's answer: what I want isn't possible. – Tohuw Nov 23 '18 at 16:42
-3

I managed to solve this problem. You have to give up on mic. So go to Sounds then recording and turn off your headphones mic. Enjoy.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.