1

I have a tablet that run Windows 8.1 RT. I did a restore few days ago then I started do the updates availables in Windows Update. After a few Update/Reboot cycles, KB 2919355 April 2014 Update 1 was installed and now Windows Update keep searching for update forever. I've tried everything I found on the net to fix this (Windows Update Troubleshooter, stop the service / delete c:\Windows\SoftwareDistribution folder, etc.) but I can get this fixed.

I found two similar posts for Windows 8.1 with accepted answer that suggest to install KB3102812:

  1. Cannot install any updates on clean Windows 8.1
  2. https://answers.microsoft.com/en-us/windows/forum/windows8_1-update/windows-81-windows-update-stuck-at-checking-for/c0d42129-7479-44cb-a150-a95ad707ab2b

However, the tablet run Windows RT and KB3102812 page (https://support.microsoft.com/en-us/kb/3102812) state that :

The update for Windows RT 8.1 can be got only from Windows Update.

The update is also not available on the Windows Update Catalog for ARM architecture.

Does anyone has a suggestion to fix this Windows Update issue or any hint where I could go to download the KB3102812 for RT?

EDIT

I now know from Microsoft Support that installing KB3138615 should fix the issue but I still can't find a link to manually download this update for ARM devices.

  • have you tried the MSU from my link? Does this work? – magicandre1981 Jan 13 '17 at 18:41
  • Yes thank you so much for providing this link. You're the first person out of 10 who understand it is an ARM device and doesn't send me a x86 or x64 link for this update :-) I installed it yesterday without any problem. After a reboot I started a new scan for update. Unfortunately the issue with Windows Update seem to be still present. I tried to reboot again this morning and run the Windows update troubleshooting tool. I started a new scan for Update but I had to left for work so I don't know yet if it succeed or not. I will let you know if it worked or not. – LH05 Jan 13 '17 at 21:37
  • Installing the KB3138615 fixed my issue with Windows Update. It tooks 4 hours to complete the search process but it cames out with 188 new updates! Thanks magicandre1981 – LH05 Jan 15 '17 at 6:45
  • You're welcome. Save the MSU on your onedrive if you have to reset the tablet again. – magicandre1981 Jan 15 '17 at 8:05
1

You can download the update kb3138615, which includes the latest Windows Update Agent, from this link. Also stop Windows Update service like in Windows 7 to avoid the hang at "Searching for updates on this computer" while trying to install the MSU.

0

Can you please describe step by step, how did you install the kb3138615? When I try to install the downloaded msu file, it creates a new folder in C:, which contains the following files:

Windows8.1-KB3138615-arm.cab

Windows8.1-KB3138615-arm.xml

Windows8.1-KB3138615-arm-pkgProperties.txt

WSUSSCAN.cab

and then the installation hangs at "Searching for updates on this computer". I do not understand the linked article how to avoid that.

I found some advice, how to install an update cab files so I restarted the tablet, then I launched Command Promt as an administrator and used the follovig command:

dism /online /add-package /packagepath:"C:\foldername\Windows8.1-KB3138615-arm.cab"

It seems the update KB3138615 is installed.

Then I had to restart the tablet, run the Windows update troubleshooting tool and after another restart the Windows Update service started to work.

So it is OK now, but I am not sure about my installation method of the kb3138615. There is also the WSUSSCAN.cab in the folder and I didn't install it. Is it OK?

In any case I would like to know, how to install the KB3138615 msu file next time better way and avoid the hang at "Searching for updates on this computer".

  • looks like a compression store app stole the .MSU file extension . Do a rightclick on the MSU and select "Open with" and here select the WUSA.exe from C:\Windows\System32 – magicandre1981 Jan 16 '17 at 16:32
  • I agree with magicandre1981 answer. On my side, I just double-clicked the .msu file and it popped the Update Installation Window. – LH05 Jan 17 '17 at 20:15
  • For the "Searching for updates on this computer" issue, you have to stop the Windows Update service before executing the msu. To stop it you can type "net stop wuauserv" in command prompt or use the Service Management Console (search for "service" in the start menu). – LH05 Jan 17 '17 at 20:22
  • I think that only problem was, that I didn't stop the Windows Update service. The .msu is associated with "Windows Update Standalone Instaler". But the dism command worked for me too, Windows is already fully updated. Thank you both for your help. – user684923 Jan 18 '17 at 9:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.