22

I want to copy the text that is in revisions marked as deleted - and paste it to another document. But when I mark it with mouse and do Ctrl-C it says "The selection is marked as deleted text" and nothing is copied to the clipboard.

UPDATE: is there a solution without rejecting the deletion?

  • Can you paste in notepad ? – malat Jan 9 '17 at 13:07
  • 2
    Not posting as an answer since it involves rejecting changes... One solution would be to make a copy of your doc and then reject all changes in the copy. (You can reject all changes in one action.) Your original doc still has all the changes, your new doc is a historical version without the changes (deletions). You can now simply copy and paste from the new doc. – chue x Jan 9 '17 at 20:44
22

Is there any solution without rejecting the deletion?

Solution 1:

  1. Select the deleted text plus an extra word.

  2. Then you should be able to copy without getting the error message.

  3. Paste the text into the other document.

  4. Delete the extra word.

Source Can't copy text marked as deleted

Solution 2:

Use the following VBA code:

Option Explicit

Public myString As String

Sub CopyMyDelete()
' Alt-1 is shortcut
myString = Selection.Text
End Sub


Sub PasteMyDelete()
' Alt-2 is shortcut
Selection.TypeText myString
End Sub

Now I can go into any TrackChange balloon, select deleted text and hit Alt-1. Yes, perhaps it is silly, but you can not copy selected deleted text in VBA either. However, you can make a public string variable that selected text.

Now I can move the Selection out of the balloon, and where ever I want, I can Alt-2 and the previously selected deleted text is typed in. It will of course be marked as a Track Change insert.

Note that when you move the Selection out of the TrackChange ballon (where you grabbed the deleted text) you can use the Selection however you like. The deleted text contents are in a string variable, NOT text associated with the selection itself. You can do other stuff, and when you want - type in the deleted text with an Alt-2.

Source Word says "marked as deleted text"

  • it is maddening but unsurprising Solution 1 works – Charles Wesley May 30 '18 at 22:58
  • 1
    If Solution 1 appears not to work, be sure to "paste as text" instead of the default paste formatting method. Solution 1 will always work if the target application is plain text only. – Jirka Hanika Jul 11 '18 at 9:33
7

You can follow this process:

  • reject deletion
  • select the text and press copy
  • insert the text
  • go back to Word and undo rejection
  • 4
    Yeah this is the obvious one - but rejecting deletion is pain in the ass. I would like to have a solution without this – Tomas Jan 9 '17 at 12:15
  • 2
    why do you think it's a pain? Does it take long? Do you need many time to find it in the menu? – Máté Juhász Jan 9 '17 at 12:17
  • 4
    That part was added to the question AFTER my answer. I think it would be unfair to remove it as it DOES ANSWER the original question. – Máté Juhász Jan 9 '17 at 18:33
  • Ah. Sorry I didn't notice that. I've removed my comment. – DavidPostill Jan 9 '17 at 21:00
  • 4
    @Tomas Since you have updated the question (and invalidated this answer in the process) it would be useful to add to the question why you want to avoid rejecting the deletion, since that seems like an otherwise reasonable process. – GalacticCowboy Jan 9 '17 at 21:56
2

Yes, with no need to copy anything extra, reject changes, or use VBA. Simply turn off Track Changes, and then you can copy the deleted text without any issues. Don't forget to turn it back on before making further edits to the document.

(Tested on Word 2007 because work still lives in the past, but I recall this working in 2010, and at least as far back as 2003. I can't imagine they would have changed this in the latest version.)

This generalizes for what changes can be copied and pasted into another Word document, and whether they are pasted as changes or not.

            +-------------------------------------------------------------------+
            | Destination                                                       |
            | TC On                          | TC Off                           |
+-----------+--------------------------------+----------------------------------+
| S  TC On  | All existing and inserted text | All existing and inserted text   |
| o         | pasted as inserted text. No    | pasted normally. No deleted      |
| u         | deleted text included.         | text included.                   |
| r --------+--------------------------------+----------------------------------|
| c  TC Off | All existing and inserted text | Existing text pasted normally,   |
| e         | pasted as inserted text.       | insertions pasted as insertions, |
|           | Deletions pasted as deletions. | deletions pasted as deletions.   |
+-----------+--------------------------------+----------------------------------+
0

You can save the document as-is, open it in Notepad, find the important section by searching for particular phrases, copy the needed text, paste into the target, and close Notepad. Don't save from Notepad and don't leave multiple copies of the document open. This method will introduce extra characters and formatting you'll need to clean up in the target, especially if the copied text spans multiple paragraphs or both deleted and non-deleted text.

0

Here is another way (which after the frustrations of trying other options, actually worked well, and is simple):

  1. Identify the text with "strike through" that you wish to copy from Deleted Text.
  2. Right Click, and when that shows you options, choose REJECT CHANGE. That immediately changes the text back to regular (which is to say: it removes the "strike through")
  3. Click COPY on that as it will remain shadowed (and then transfer the clean text to another document, if that's your intention)
  4. Finally, go to TOOL BAR's "UNDO TYPING" icon at the top. Click on it. That will reverse your earlier action (which is to say it reinstates the "strike through" and returns text to the way it was moments ago. Hope that helps...

Not the answer you're looking for? Browse other questions tagged or ask your own question.