22

I'm using PuTTY to ssh into a Debian machine. When I try to use Ctrl + [arrow key] to resize panes in tmux, the active pane just switches as if I was not holding Ctrl. Other Ctrl key shortcuts work fine. When I try the same thing using a different terminal, the shortcut works.

2 Answers 2

18

Add the following line to ~/.tmux.conf

set -g terminal-overrides "xterm*:kLFT5=\eOD:kRIT5=\eOC:kUP5=\eOA:kDN5=\eOB:smkx@:rmkx@"

Source: https://stuff.mit.edu/afs/athena/project/bsd/src/tmux-1.3/FAQ

Ctrl and arrow keys doesn't work in putty! What do I do?

putty inverts the sense of the cursor key mode on ctrl, which is a bit hard for tmux to detect properly. To get ctrl keys right, change the terminfo settings so kUP5 (Ctrl-Up etc) are the adjusted versions, and disable smkx/rmkx so tmux doesn't change the mode. For example with this line in .tmux.conf (assuming you have TERM set to xterm):

set -g terminal-overrides "xterm*:kLFT5=\eOD:kRIT5=\eOC:kUP5=\eOA:kDN5=\eOB:smkx@:rmkx@"

Note that this will only work in tmux 1.2 and above.

1
  • Doesnt work. How to make it work?
    – Kangarooo
    Jan 10, 2021 at 23:59
0

Ctrl+b then release both and then Ctrl+arrow key to adjust size(holding Ctrl press fast multiple times arrow if needed)

Make sure that you don't have a long pause between pressing, otherwise it will resize just one step at time

3
  • 1
    That's what I am doing and it doesn't work Jan 10, 2017 at 14:58
  • Pause between Ctrl+b and subsequent Ctrl+arrow key must be as short as possible, (I think it a second, no more). This bothered me too until I found that it need to be entered pretty fast
    – Alex
    Jan 10, 2017 at 15:36
  • 1
    Using Putty 0.69 on Windows and tmux 2.1 on Ubuntu 16.04, Ctrl + Arrow is just detected the same as arrow without Ctrl. Setting the terminal overrides as suggested in the other answer fixes things.
    – bobpaul
    Jun 20, 2017 at 17:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .