I just recently purchased a Linksys RE7000 range extender to strengthen my wireless signal into the back yard.

My current network is as follows:
This router connects directly to the Internet and is used as a wired & wireless router. There are two wireless networks (lets call them WiFiConnect2.4Ghz and WiFiConnect5.0Ghz.
DHCP is set to ON for the range -
Router IP:
Subnet Mask:

This router connects to MainRouter via ethernet cable. It acts as an access point (wired and wireless). There are two wireless networks, which are the same SSID and passwords as MainRouter.
DHCP is set to OFF.
Router IP:
Subnet Mask:

This setup (whether it's correct or not) works seamlessly. I can access both routers from any device no matter what router the device is directly connected to via Ethernet cable, and WiFi does not drop while moving throughout the house. I used the same SSIDs so that FaceTime/Skype wouldn't drop while going in different sections of the house.

Here's my problems:
I set up the RE7000 as just a range extender (running an Ethernet cable to it to use as an access point is not an option here). I don't believe it's connecting to the WiFi signal from the router it's closest to. If I use my cell phone or laptop, signal strength of the WiFi signals are very strong (near SecondaryRouter at the location of the RE7000), but the signal strength of the WiFi connection that the RE7000 is using is very weak. I feel like it's trying to connect to the WiFi signal sent by MainRouter (which is very far from it) instead of the WiFi signal coming from SecondaryRouter (which is near it). I can tell it's weak as the RE7000 has a meter strength bar in it's settings page and an indicator light on the unit.
RE7000 IP:
RE7000 Subnet:
RE7000 Gateway:
RE7000 DNS:
RE7000 WiFi Networks: WiFiConnect_Ext2.4Ghz and WiFiConnect_Ext5.0Ghz

Are there any special settings I can use to force the RE7000 to use the WiFi signal from a particular router?
Am I correct using the Secondary Router IP address as the Gateway and DNS for the RE7000 Range Extender or should I use the IP from MainRouter since that is what directly accesses the Internet?
As a side question, can I use the same WiFi network SSID and passwords on the RE7000 as I do with the other two routers without any issues?


  • I have the R7000 you can either use it to extend your network using one band to connect to your network and the other will be used to extend it OR you connect to your Network by LAN and extend both bands. Those are the only two modes the R7000 support. You mention the signal strength it's usingnis weak but mention your using a LAN cable those two statements contradict each other. During the setup you can choose which band to use to connect to your network, it sounds like, you selected the wrong one – Ramhound Jan 10 '17 at 1:27

You have Router 2 configured wrong for a roaming network, so I'm kinda surprised that you say you can roam between routers without dropping a FaceTime or Skype call.

You really want Router 2 to have its DHCP Server disabled, give it an unused 192.168.1.x address on its LAN side, and connect one of its LAN ports to the Ethernet cable that goes to Router 1. This makes Router 2 just a simple AP, not a router or server. That way your whole home LAN is all one big bridged/switched Ethernet LAN and all one big IP subnet, no matter which "router" you happen to be connected to.

Also, double check that you really have the exact same SSIDs, security mode*, and passphrase configured for both APs. Make sure you have the exact same capitalization, punctuation, and spaces. Make sure you have no accidental trailing spaces. I ask you to do this because I can't believe your clients were truly roaming before while maintaining FaceTime and Skype calls.

Then, once you've got proper roaming working, Let your RE7000 join the network (it should join the nearest AP) and it should get its config dynamically from the main router.

*As for security mode, I strongly recommend pure WPA2-PSK, meaning only AES-CCMP, no TKIP; TKIP was part of original WPA, is no longer needed, and causes problems.

  • I made a typo in the initial post, Router 2 has DHCP DISABLED. It is wired as your recommendation already. However I still don't believe the new RE7000 is connecting to the WiFi that Router 2 is broadcasting as it's signal strength is weak near it. – Stephen Cavallo Jan 10 '17 at 23:16
  • Can you edit your Question and fix all your typos? Not just the one you mentioned, but double-check that you have your subnet masks, not gateways set to You have two places that you said your gateway was You didn't even capitalize your two example SSIDs the same way. This is why I was asking you to carefully double-check every last detail of your wireless setup, looking for tiny differences in the SSIDs. By the way, you should NOT configure the RE7000 to use Router 2 for anything. Router1 should be your only real router. – Spiff Jan 10 '17 at 23:22
  • I edited my original post. I'll adjust the RE7000 settings to use (the Router1 address) for communication and see if that helps. – Stephen Cavallo Jan 16 '17 at 0:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.