0

A friend handed me an Acer Aspire one D270 running windows 7 which boots as normal and I assume logs in since there was no password, but then displays a black screen with the cursor.

  • I cannot do a system restore as there is no restore point.
  • Both the normal boot and safemode display a black screen with a cursor
  • From this state, I cannot directly open the command line or the task manager using the shortcuts

I managed to get to the recovery options by hitting F8 on boot, and I managed to access cmd from here. Running task manager shows explorer.exe is not among the running processes, which I assume is problem. A long hunt led me to try changing the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon shell value to explorer.exe(I found it had been changed to cmd.exe /k start cmd.exe), then restating for it to take effect. It however for some reason keeps changing back every time I restart.

I then did a malware and virus scan with VIPRERESCUE, found a few Trojans which were removed, then tried changing the Shell value again, and it still doesn't get applied.

  • Attempting to run Explorer via the taskmanager says Widows can't find explorer.
  • Using notepad->file->open to access explorer and try running it from windows/explorer.exe says explorerframe.dll is missing.
  • Replacing the .dll file still doesn't help.
  • I can't run the sfc scan because it says Windows is in recovery mode.

I really need some help guys. Thanks in advance.

0

Sorry to hear of these troubles. Are you hoping you get the system working again from where it is now?

One solution could be to boot to safe mode, get cmd.exe running, transfer any user data an external USB drive, and reinstall the operating system. If you do this, remember to scan the recovered data for malware.

Best of luck, Alex

0

I've had this problem occur with a Windows 7 Ultimate x64 and none of the various guides have helped so far.

Naturally there were no system restore points, most likely if there had been I wouldn't have had so much drama

Steps tried were:

  • Replacing the registry hives from backup
  • sfc /scannow's
  • bcdedits etc.
  • replacing the boot folder from a working windows
  • and probably a bunch more that I can't remember

I ended up taking the hard drive out to grab any user files, in preparation for nuking from orbit. In doing so I had to replace the NTFS permissions in order to access the drive. I got lazy/annoyed and just added Everyone permission to all files and folders on the drive.

Once it was back in its own computer, windows loaded up and acted like nothing had ever happened. It was just one of those "let's just see what will happen if..." moments.

So, at some point this problem seems to be solved by a permission issue. Hopefully that someone with more time/persistence finds this and solves this irritating problem.

Edit - the problem with this approach is that now every system file across the board has Everyone permission set, which is probably not a good thing for security. Also the windows was kinda not quite right afterwards, and is being nuked from orbit anyway. However, this might just be enough for folks to save a lot of time recovering their files.

0

In case someone else comes across this issue and none of the other solutions help, I just encountered it after installing a VPN, used the of using notepad to go and find explorer.exe, because like the OP, task manager couldn't find it. Found out that for some reason my explorer.exe got changed into explorer_backup.exe and replaced it with an explorer.tmp, so I just named explorer.tmp to explorer.exe and it worked again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.